Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

custom workflow build build error

manikanthar1295
Level 4
Level 4

Hi Team,

i have written custom workflow and started building the code.

but while building cod i am getting error like below

 

Class com.btr.bck.workflow.core.wfprocess.customWorkFlow is not assignable to specified service com.adobe.granite.workflow.exec.Workflow
[ERROR] Error(s) found in bundle configuration

 

Any suggestion to solve this

 

1 Accepted Solution
markus_bulla_adobe
Correct answer by
Employee
Employee

Hi @manikanthar1295!

Could you please share the source code of your custom workflow?
Without that it's quite hard to give advice.

 

A first shot into the dark:

  • Does your workflow step class have an according @Component annotation?
  • What service class is the component assigned to (e. g. service = WorkflowProcess.class)?
  • Does your workflow step class implement that assigned class (e. g. public class MyWorkflowStep implements WorkflowProcess)?
  • Are you importing the correct assigned class (e. g. import com.adobe.granite.workflow.exec.WorkflowProcess)?

View solution in original post

2 Replies
markus_bulla_adobe
Correct answer by
Employee
Employee

Hi @manikanthar1295!

Could you please share the source code of your custom workflow?
Without that it's quite hard to give advice.

 

A first shot into the dark:

  • Does your workflow step class have an according @Component annotation?
  • What service class is the component assigned to (e. g. service = WorkflowProcess.class)?
  • Does your workflow step class implement that assigned class (e. g. public class MyWorkflowStep implements WorkflowProcess)?
  • Are you importing the correct assigned class (e. g. import com.adobe.granite.workflow.exec.WorkflowProcess)?

View solution in original post

manikanthar1295
Level 4
Level 4

Hi markus_bulla_adobe,

 

Thanks for your quick response.

 

I found root cause for the issue 

 instead of service = WorkflowProcess.class I have user service Workflow.class.

I have corrected now its building