Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Custom tab not coming properly

Avatar

Level 1

The fields under custom tab of page properties not loading intermittently in AEM 6.5.

2 Replies

Avatar

Community Advisor

Could you please share more detials here?

what do you meant by not coming properly? is not visible? or have alignment issue?

Avatar

Level 1

sometimes previous tabs fields are persisting when we click on custom tabs and sometime its own fields are coming properly. In the attached SC,  I have clicked on Global XF Configuration tab but the fields are from "Basic"Capture.PNG

Avatar

Community Advisor

Hi,

It could be because of basic tab fields are inherited in your custome tab.

 

Could you please share the custom tab and you implementation of page dialog overlay/override.

Avatar

Community Advisor

I have replicated the this situation and here Basic and Global XF Configuration are reflecting same value -

 

Basic tab -

 

DEBAL_DAS_0-1641745854245.png

 

Global XF Configuration -

 

DEBAL_DAS_1-1641745904686.png

 

Following situation: if two different fields under same tab or different tabs are having similar value, normally it happens when same property name like name="./id" is being used for the fields as shown below -

 

DEBAL_DAS_2-1641748625313.png

 

 

Avatar

Level 2

Hi , 

 

Is this issue happening for all custom tab or specific .

 

Possible reason

 

1) If any of the fields that are present in the custom tab has some issue with configuration . 

2) Network delay or any JavaScript error blocking the execution 

Please view the browser console to confirm if there are any issues