Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Custom Content Builder for Replication

Avatar

Avatar
Validate 1
Level 2
krishnak3067714
Level 2

Likes

3 likes

Total Posts

15 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
krishnak3067714
Level 2

Likes

3 likes

Total Posts

15 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
View profile
krishnak3067714
Level 2

12-05-2017

    Hi,

    I'm successfully able to create a content builder for custom replication. 

    It is working as expected with default settings. But when I enable "Enable Batch Mode" it's not working.

    The error I'm getting is 

Error during replication of ReplicationAction{type=ACTIVATE, path[0]='batch:', time=1494623228329, userId='', revision='null'}: com.day.cq.replication.ReplicationException: Could not retrieve content from content builder

Inside custom transport handler, if batch enabled - the IOUtils.toString(replicationTransaction.getContent().getInputStream()); is returning 

What I get if I try without batch is highlighted with red box. 

Please help me. Thanks. 

Replies

Avatar

Avatar
Validate 10
Level 3
anjali_biddanda
Level 3

Likes

17 likes

Total Posts

69 posts

Correct Reply

6 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 10
Level 3
anjali_biddanda
Level 3

Likes

17 likes

Total Posts

69 posts

Correct Reply

6 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile
anjali_biddanda
Level 3

13-05-2018

Hi krishnak30677142

I'm facing the same issue with my custom replication agent. Can you share what you did to fix it?

Thanks,

Anjali