Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Create Sub Assets Problem after installing AEM 6.2 Service Pack 1

pietrog32181931
Level 1
Level 1

Hi Everyone,

We installed Service Pack 1 on AEM 6.2 author environment.

After that the Workflow process step  "Create Sub Assets" doesn't work anymore.

This the log.

19.10.2017 11:29:41.835 *DEBUG* [JobHandler: /etc/workflow/instances/server0/2017-10-19_1/update_asset_14:/content/dam/test-gw/GDE Albero.pdf/jcr:content/renditions/original] com.day.cq.dam.handler.standard.pdf.PdfHandler Exception occurred while deleting pages relation

com.adobe.granite.asset.api.AssetException: Failed to remove relation

at com.adobe.granite.asset.core.impl.AssetImpl.removeRelation(AssetImpl.java:288)

at com.day.cq.dam.handler.standard.pdf.PdfHandler.cleanup(PdfHandler.java:506)

at com.day.cq.dam.handler.standard.pdf.PdfHandler.processSubAssets(PdfHandler.java:419)

at com.day.cq.dam.core.process.CreateSubAssetsProcess.execute(CreateSubAssetsProcess.java:51)

at com.day.cq.workflow.compatibility.CQWorkflowProcessRunner.execute(CQWorkflowProcessRunner.java:93)

at com.adobe.granite.workflow.core.job.HandlerBase.executeProcess(HandlerBase.java:189)

at com.adobe.granite.workflow.core.job.JobHandler.process(JobHandler.java:244)

at org.apache.sling.event.impl.jobs.JobConsumerManager$JobConsumerWrapper.process(JobConsumerManager.java:500)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.startJob(JobQueueImpl.java:291)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.access$100(JobQueueImpl.java:58)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl$1.run(JobQueueImpl.java:227)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

at java.lang.Thread.run(Thread.java:748)

Caused by: javax.jcr.PathNotFoundException: pages not found on /content/dam/test-gw/GDE Albero.pdf/jcr:content/related

at org.apache.jackrabbit.oak.jcr.session.NodeImpl$11.perform(NodeImpl.java:632)

at org.apache.jackrabbit.oak.jcr.session.NodeImpl$11.perform(NodeImpl.java:626)

at org.apache.jackrabbit.oak.jcr.delegate.SessionDelegate.perform(SessionDelegate.java:208)

at org.apache.jackrabbit.oak.jcr.session.ItemImpl.perform(ItemImpl.java:112)

at org.apache.jackrabbit.oak.jcr.session.NodeImpl.getProperty(NodeImpl.java:626)

at com.adobe.granite.asset.core.impl.AssetImpl.removeRelation(AssetImpl.java:285)

... 13 common frames omitted

After that the workflow skip the step and move forward.

I already try to install cumulative fix pack 1 but without any succes.

Can anyone help me??

1 Accepted Solution
piyushn29363104
Correct answer by
Level 2
Level 2

Hi pietrog32181931​,

From 6.2 SP1 onward, sub-asset generation has been disabled by default. See CQ-95505 at 6.2 Service Pack 1 Release Notes .

To generate sub-assets, one needs to specify Max. Number of Pages under the com.day.cq.dam.handler.standard.pdf.PdfHandler.name bundle configuration which is by default set to 0.

1332040_pastedImage_0.png

Could you please check that the value is not set to 0 if you want to generate sub-assets ?

Also, once you change the default value, only the assets uploaded after it will have sub-assets generated.

I checked that with Max. Number of Pages not set to 0, sub assets are generated on 6.2 SP1.

View solution in original post

7 Replies
kautuk_sahni
Community Manager
Community Manager

I have asked the internal experts to have a look at this one.

~kautuk

amitgupta_adbe
Employee
Employee

given error stack does not result in a failure. It is just a debug log. I would suggest you to create a support ticket with complete logs and pdf in question. Just to confirm, same pdf was working, before you installed the service pack1. And you have issues with all pdfs and not just this specific pdf?

pietrog32181931
Level 1
Level 1

Hello,

I have two different instances of AEM author in two different environment.

before I installed the SP1 in both environment the workflow worked with all kind of PDFs file.

After the installation the workflow didn't work anymore with any PDF in any folder of the DAM.

I doesn't have any stack error because thre is no error in logs.

piyushn29363104
Correct answer by
Level 2
Level 2

Hi pietrog32181931​,

From 6.2 SP1 onward, sub-asset generation has been disabled by default. See CQ-95505 at 6.2 Service Pack 1 Release Notes .

To generate sub-assets, one needs to specify Max. Number of Pages under the com.day.cq.dam.handler.standard.pdf.PdfHandler.name bundle configuration which is by default set to 0.

1332040_pastedImage_0.png

Could you please check that the value is not set to 0 if you want to generate sub-assets ?

Also, once you change the default value, only the assets uploaded after it will have sub-assets generated.

I checked that with Max. Number of Pages not set to 0, sub assets are generated on 6.2 SP1.

View solution in original post