Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Create Page Option appears to be null and not available in AEM

Avatar

Level 2

Hi ! , After creating components and templates in CRX ,I couldn't create a page with newly updated template, Since the "Create Page" option isn't available [ Sites -> Create -> "Create Page" ]

I've installed AEM twice and the issue persists, Kindly help ! 🙂

1 Accepted Solution

Avatar

Correct answer by
Level 4

I'm not familiar with the newer projects interface, but I've experienced a similar issue with the older Site Admin (/siteadmin).

The issue that I've experienced seems to occur if any piece of content (at least top-level content, possibly even nested content) becomes "corrupt", by missing it's jcr:content child node.  If this is the same problem, you should be able to explore the repository with CRXDElite (/crx/de/index.jsp#/content) and either add the missing jcr:content nodes, or delete any content nodes that are missing their jcr:content child node.

View solution in original post

5 Replies

Avatar

Correct answer by
Level 4

I'm not familiar with the newer projects interface, but I've experienced a similar issue with the older Site Admin (/siteadmin).

The issue that I've experienced seems to occur if any piece of content (at least top-level content, possibly even nested content) becomes "corrupt", by missing it's jcr:content child node.  If this is the same problem, you should be able to explore the repository with CRXDElite (/crx/de/index.jsp#/content) and either add the missing jcr:content nodes, or delete any content nodes that are missing their jcr:content child node.

Avatar

Level 1

Hi Dave,

 

We are facing similar issue in our lower environment AEM cq 5.6.Site admin menu options like new,copy,delete,activate ,deactivate,workflow, search label are disappeared in siteadmin. Please find the attached screenshot.

Please let us know the possible solutions.Siteadmin menu options are disappeared.png

 

Avatar

Level 2

Dave Hughes wrote...

I'm not familiar with the newer projects interface, but I've experienced a similar issue with the older Site Admin (/siteadmin).

The issue that I've experienced seems to occur if any piece of content (at least top-level content, possibly even nested content) becomes "corrupt", by missing it's jcr:content child node.  If this is the same problem, you should be able to explore the repository with CRXDElite (/crx/de/index.jsp#/content) and either add the missing jcr:content nodes, or delete any content nodes that are missing their jcr:content child node.

 


Yes , "Create Page" option is visible now ! Thank you so much !

Avatar

Level 4

Happy to help.  

I've seen several other individuals trip over this before as well.  I'm not sure how it is that the problem is so common, as it seems to require that a user delete/renames a node that they should not, but it does seem to happen alarmingly frequently.  I'd love to see Adobe make the Projects and Site Admin interfaces more durable, so they don't just fail silently under these conditions.

Avatar

Level 2

True that ! I was new to AEM and am starting this up from the scratch ! Your info really helped 🙂