Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Create offer request failed - error while syncing an activity from AEM to Adobe Target

prashantonkar
Level 4
Level 4

I am getting "Create Offer Request Failed!" error while pushing an activity from AEM to Adobe Target.

1834631_pastedImage_0.png

Log Entries:

{"httpStatus":403,"requestId":"qaYhfw4FXTWREsiNLNl1RBVjOSrmZ0kC","requestTime":"2020-04-16T13:25:19.697Z","errors":[{"errorCode":"Forbidden.Resource","message":"Access denied. To perform this operation, all of the following privileges are required \"[editor]\"."}]}

 

As mentioned in this post, I have also provided "Editor" product role to my integration. Is there any thing that I may be missing? One more thing to note here is the target workspace. When it is "Default Workspace" it works fine. If the workspace is anything other than "Default Workspace" I get the above error.

 

Reference: https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/problem-when-export-experi...

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution
shreyag72517995
Correct answer by
Employee
Employee

Thanks for your request. I am assuming you are using IMS integration. Could you confirm you AEM version?

 

For AEM 6.5.1, as documented in [2], the customers should follow approach as mentioned in [1]. 

AEM 6.5.2 onwards customers can choose to use [3]. It seems like you have followed [3] in your AEM 6.5.1 environment.
[1] https://docs.adobe.com/content/help/en/experience-manager-65/administering/integration/target.html

[2] https://docs.adobe.com/content/help/en/experience-manager-65/administering/integration/experience-fr...

[3] https://docs.adobe.com/content/help/en/experience-manager-65/administering/integration/integration-i...

 

Please confirm if you are not using Adobe I/o and what is your AEM version?

View solution in original post

7 Replies
shreyag72517995
Correct answer by
Employee
Employee

Thanks for your request. I am assuming you are using IMS integration. Could you confirm you AEM version?

 

For AEM 6.5.1, as documented in [2], the customers should follow approach as mentioned in [1]. 

AEM 6.5.2 onwards customers can choose to use [3]. It seems like you have followed [3] in your AEM 6.5.1 environment.
[1] https://docs.adobe.com/content/help/en/experience-manager-65/administering/integration/target.html

[2] https://docs.adobe.com/content/help/en/experience-manager-65/administering/integration/experience-fr...

[3] https://docs.adobe.com/content/help/en/experience-manager-65/administering/integration/integration-i...

 

Please confirm if you are not using Adobe I/o and what is your AEM version?

View solution in original post

prashantonkar
Level 4
Level 4

Thanks for your reply @ shreyag72517995

I upgraded my AEM to 6.5.2.

 

According to link [2]

Experience Fragments can be exported to either:
  • the default workspace.
  • a named workspace, specified in the Cloud Configuration.

But I am not getting any option to specify the workspace name in cloud configuration.

prashantonkar
Level 4
Level 4
Sorry, I found the workspace configuration in cloud service configuration of experience fragments. But anyways, I am getting the same error even after configuring the workspace.
prashantonkar
Level 4
Level 4

@shreyag72517995Seems like my permissions were over written by someone. After giving "approver" access, this integration is working fine. But is there a way to make this work for "Activity" which has been created in AEM too? As of now, I am getting same error for activity. I don't see Workspace configuration for activity. Any idea if this has been fixed in 6.5.3 or 6.5.4 ?

test1234567
Level 2
Level 2
@shreyag72517995 - I am getting the same error and using AEM 6.5.0. Can you tell me what should I do to resolve the issue?
mrivas-xpediant
Level 1
Level 1

Hi all,

I have been troubleshooting this issue with all the steps mentioned in this thread.

I am currently running AEM 6.5 with SP8, have "Editor" role in the Target console and have the ability to change roles; I have currently tried swapping within Approver/Editor/Publisher roles and none of them seems to let me synchronize my local Activities to Adobe Target due to the same error described in the logs.

Is there any other workaround that I should try? The only missing thing that I have not tried yet, is to remove the target configuration from my local AEM environment, everytime that I switch roles in Adobe Target, which doesn't seems to make much sense, but would be next steps that I could try.