Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

ContextHub flickering the screen

Avatar

Level 2

Hi, we are trying to use ContextHub to implement personalisation (segmentation) on our website.

We were able to implement it correctly. Everything is OK, but in some computers, we don't know why, the screen flickers before displaying the final content.

In some computers:

a) First, it displays the Default content (without segmentation applied).

b) Then, after 1 second, the screen changes completely to match the segmentation.

Anyones knows why this is happening? We want to see the final content with segmentation applied without the page flickering.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Not sure but that could be because of network/machine related issues that the libraries take time to load & process. For the m/c where you notice the error, do they have local AEM or they use the same remote/cloud AEM server?

Couple of pointers to debug:

  • Check the page load time in network tab of developer toolbar or even in 'Developer' mode or use a plugin
  • Look for any errors/warnings in the console tab of developer toolbar or server logs
  • Try to find a pattern based on OS/Browser/network/memory/cpu combination

View solution in original post

3 Replies

Avatar

Correct answer by
Community Advisor

Not sure but that could be because of network/machine related issues that the libraries take time to load & process. For the m/c where you notice the error, do they have local AEM or they use the same remote/cloud AEM server?

Couple of pointers to debug:

  • Check the page load time in network tab of developer toolbar or even in 'Developer' mode or use a plugin
  • Look for any errors/warnings in the console tab of developer toolbar or server logs
  • Try to find a pattern based on OS/Browser/network/memory/cpu combination

Avatar

Level 2

I am really working in a very restricted network environment, where we have a strong proxy with lots of blocked websites and strict monitoring of information.

It may be that our proxy is slowing down the loading of some scripts. But I am not sure yet what is the root of the problem.

Avatar

Community Advisor

very likely but proxy would have same impact on all m/c, its sort of a combination of multiple reasons..