Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Content Fragment Creation using Post Asset API return 403 Forbidden status

Mahamood
Level 3
Level 3

I am following the tutorial mentioned in adobe link https://docs.adobe.com/content/help/en/experience-manager-learn/sites/content-fragments/content-frag...

and in that specific section "Using the Assets HTTP API" . There is sample CURD operation available Example POSTMAN Requests: CRUD-CFM-API-We.Retail.postman_collection.json . On running post operation I am getting 403 exception. The get operation works fine after providing basic authentication value. For Post operation even after providing basic authentication it return 403 status only.

Is there any security setting I am missing ?

The AEM version is 6.5.2 and trying this exercise in fresh vanilla instance.

1 Accepted Solution
Mahamood
Correct answer by
Level 3
Level 3

The issue is resolved. My bad this issue was appearing due to office proxy restriction. With personal internet connection it is working fine. Unfortunately in logs I did not find any mentioned on proxy or connection issue so it took time to figure out what is causing the issue.

View solution in original post

2 Replies
Mahamood
Correct answer by
Level 3
Level 3

The issue is resolved. My bad this issue was appearing due to office proxy restriction. With personal internet connection it is working fine. Unfortunately in logs I did not find any mentioned on proxy or connection issue so it took time to figure out what is causing the issue.

View solution in original post