Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Content exposed as json is not working in publisher

AEMnewbie
Level 4
Level 4

We are currently using AEM 6.5 SP 6.5.6 . Code is failing to work in publisher , works fine in author instance

 

Author : content/*/en/*/jcr:content.service/*.json - Works fine

Publisher: content/*/en/*/jcr:content.service/*.json - Fails to work

 

I did check the bundles in both instance - Bundles are active 

Tried restarting the bundle in publisher . Also tried restarting the instance. Still the publisher fails to work

 

Is there a way to check when we  hit content/*/en/*/jcr:content.service/*.json is our core bundle actually being called ? -- How could we possibly troubleshoot this kind of issues?

1 Accepted Solution
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

you can use sling servlet resolver to check which servlet is getting called when you hit that page and try to change jcr:content with _jcr_content in the url

View solution in original post

1 Reply
Anudeep_Garnepudi
Community Advisor
Community Advisor

Hi @AEMnewbie 

Please check dispatcher rules. Dispatcher might be blocking the request.

AG

Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

you can use sling servlet resolver to check which servlet is getting called when you hit that page and try to change jcr:content with _jcr_content in the url

View solution in original post