Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl No library configured at

victor_toledo_3
Level 3
Level 3

Hi all, when we open a page we can see in our log file these WARN:

02.11.2017 16:18:12.377 *WARN* [0:0:0:0:0:0:0:1 [1509650292355] GET /en_US.html HTTP/1.1] com.day.cq.wcm.webservicesupport.impl.ConfigurationManagerImpl Cloud service [] not found

02.11.2017 16:18:12.398 *WARN* [0:0:0:0:0:0:0:1 [1509650292355] GET /en_US.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl No library configured at /apps/clientlibs/granite/jquery

02.11.2017 16:18:12.398 *WARN* [0:0:0:0:0:0:0:1 [1509650292355] GET /en_US.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl No library configured at /apps/clientlibs/granite/utils

02.11.2017 16:18:12.399 *WARN* [0:0:0:0:0:0:0:1 [1509650292355] GET /en_US.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl No library configured at /apps/clientlibs/granite/jquery/granite

do you know how can I remove this warning?

AEM 6.3.0

Thanks in advance

1 Accepted Solution
kautuk_sahni
Correct answer by
Community Manager
Community Manager

Please create a support ticket for this and also share the solution with the community.

~kautuk

View solution in original post

0 Replies
smacdonald2008
Level 10
Level 10

Looks like some one placed content under /apps named clientlibs. Not really the best place to put a clientlibs. Most are placed under /etc - for example.

AClientLib.png

victor_toledo_3
Level 3
Level 3

Hey, thanks for your response. But those errors are from AEM, we have 3 instances of author/publish with 3 different sites and we have the same errors. We are migrating from 6.1 to 6.3, on 6.1 we dont have any errors/warn.

Seems to be some aem compononent/object is requesting for those paths.

I created an empty page without any component and it's the same, i have those warnings.

kautuk_sahni
Community Manager
Community Manager

Based on the previous thread [1] it seems to be Issue with ACS. Do you have ACS Commons installed?

Refer to the workaround provided:-

[1] continuous Warning in authoring ui

PS:- Linking similar issue: com.day.cq.wcm.webservicesupport.impl.ConfigurationManagerImpl Resource with path /etc/cloudservices... and Re: continuous error with ajax call to .2.html when hovering over authoring ui

kautuk_sahni
Correct answer by
Community Manager
Community Manager

Please create a support ticket for this and also share the solution with the community.

~kautuk

View solution in original post

ananta99
Level 2
Level 2

victor.toledo.3sharesmacdonald2008

Is there a resolution for this issue?

We are facing the same problem once the system is upgraded from 6.1 to 6.3. Please advise.

Thanks,

Ananta

victor_toledo_3
Level 3
Level 3

Not yet. I tried some fixes, but it seems that they do not work

victor_toledo_3
Level 3
Level 3

Hi edubey, i think you're right, if I change the allowProxy property for those paths (/apps/clientlibs/granite/jquery,

/apps/clientlibs/granite/utils, /apps/clientlibs/granite/jquery/granite) the warnings disappear

smacdonald2008 kautuksahni

I think we found something, this seems to come configured ootb, could you help us?

Thanks in advance

smacdonald2008
Level 10
Level 10

We added those instructions to the featured content at the beginning of this forum. See the Post by Peter Nash.

ananta99
Level 2
Level 2

Hi @victor.toledo.3share

Could you please share the detail steps you did to get rid of those warnings?

The paths you mentioned in the previous comment don't exist for me when I go to crx/de.

Thanks,

Ananta

victor_toledo_3
Level 3
Level 3

Sure,

I changed in the original clientlib path the property allowProxy to 'false'. For exmaple for the next WARN

02.11.2017 16:18:12.398 *WARN* [0:0:0:0:0:0:0:1 [1509650292355] GET /en_US.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl No library configured at /apps/clientlibs/granite/utils

I know that library is in /libs/clientlibs/granite/utils, so using the crx/de, go to that location and change the value.

This path /apps/clientlibs/granite/utils is requested by the new ClientLib Servlet because /libs/clientlibs/granite/utils has allowProxy = true

iamge.png

kautuk_sahni
Community Manager
Community Manager

Customer Care Link:- https://daycare.day.com/public/contact.html

If you are not to register the above then email at :- cuscare@adobe.com and request the access.

nandand81957514
Level 2
Level 2

If you change allowProxy to false under /libs...would it not get overwritten once you install an AEM Update/CFP or SP ?

victor_toledo_3
Level 3
Level 3

Hi nandand81957514 , yes, will be overwritten.  I just did it to test if that is the problem. By changing that property in those folders within libs, the warning stopped appearing. So, my conclusion was that this was the problem.