Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

com.adobe.cq.export.json cannot resolve com.fasterxml.jackson.annotation

Avatar

Level 3

Hi all

I am running a recently upgraded AEM 6.3 instance. Upgraded from 6.1

After installing AEM-6.3-Service-Pack-1, the com.adobe.cq.export.json bundle cannot resolve the com.fasterxml.jackson.annotation bundle

com.adobe.cq.export.json is version 0.0.12

com.fasterxml.jackson.annotation is version 2.8.4

The "Imported Packages" statement for com.adobe.cq.export.json has "com.fasterxml.jackson.annotation,version=[2.8,3) from com.fasterxml.jackson.core.jackson-annotations"

Give that com.fasterxml.jackson.annotation is version 2.8.4 the import statement seems valid. What am I not seeing?

Error message below:

*ERROR* [qtp998235579-61] org.apache.felix.http.jetty %bundles.pluginTitle: Cannot start (org.osgi.framework.BundleException: Unable to resolve com.adobe.cq.export.json [660](R 660.0): missing requirement [com.adobe.cq.export.json [660](R 660.0)] osgi.wiring.package; (&(osgi.wiring.package=com.fasterxml.jackson.annotation)(version>=2.8.0)(!(version>=3.0.0))) Unresolved requirements: [[com.adobe.cq.export.json [660](R 660.0)] osgi.wiring.package; (&(osgi.wiring.package=com.fasterxml.jackson.annotation)(version>=2.8.0)(!(version>=3.0.0)))])

org.osgi.framework.BundleException: Unable to resolve com.adobe.cq.export.json [660](R 660.0): missing requirement [com.adobe.cq.export.json [660](R 660.0)] osgi.wiring.package; (&(osgi.wiring.package=com.fasterxml.jackson.annotation)(version>=2.8.0)(!(version>=3.0.0))) Unresolved requirements: [[com.adobe.cq.export.json [660](R 660.0)] osgi.wiring.package; (&(osgi.wiring.package=com.fasterxml.jackson.annotation)(version>=2.8.0)(!(version>=3.0.0)))]

4 Replies

Avatar

Level 10

Have you tried checking these with AEM Dependency finder?

Avatar

Level 3

Hi

I noticed that after upgrading from 6.1 to 6.3, the "System Bundle" has "org.apache.sling.launchpad.api,version=1.1.0" in the "Import Packages" statement.

But looking at a fresh install of 6.3, I see that "System Bundle" has "org.apache.sling.launchpad.api,version=1.2.0" in the "Import Packages" statement.

What does this mean? Did my upgrade fail?

Thanks

Avatar

Level 10

The upgrade should have build this with the correct versions. I recommend opening a support ticket as you may need a hotfix.