Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

ClientLibs loaded twice on the Page

Avatar

Avatar
Validate 10
Level 3
_SumitSinghal
Level 3

Likes

5 likes

Total Posts

79 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 10
Level 3
_SumitSinghal
Level 3

Likes

5 likes

Total Posts

79 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile
_SumitSinghal
Level 3

13-09-2019

Hi Team,

I have scenario for  clientlibs  loaded twice on the page

On Template Level :

Example :

categories = [Category1]

dependencies = [category2,category3]

On Component :

categories = [Category4]

dependencies = [category2]

While on page load, I see dependencies are loaded twice using domain abc.com but loaded only once on author and publisher instance which is really strange.

Thanks

Replies

Avatar

Avatar
Contributor
Employee
hamidk92094312
Employee

Likes

102 likes

Total Posts

240 posts

Correct Reply

38 solutions
Top badges earned
Contributor
Shape 1
Ignite 1
Give Back 50
Give Back 5
View profile

Avatar
Contributor
Employee
hamidk92094312
Employee

Likes

102 likes

Total Posts

240 posts

Correct Reply

38 solutions
Top badges earned
Contributor
Shape 1
Ignite 1
Give Back 50
Give Back 5
View profile
hamidk92094312
Employee

13-09-2019

Can you clarify when this happens ? When opening the page ?

Avatar

Avatar
Validate 10
Level 3
_SumitSinghal
Level 3

Likes

5 likes

Total Posts

79 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 10
Level 3
_SumitSinghal
Level 3

Likes

5 likes

Total Posts

79 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile
_SumitSinghal
Level 3

13-09-2019

Yes on page opening .

When I checked view page source the clientlibs are loaded twice on the page .

Avatar

Avatar
Coach
Employee
jbrar
Employee

Likes

387 likes

Total Posts

869 posts

Correct Reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile

Avatar
Coach
Employee
jbrar
Employee

Likes

387 likes

Total Posts

869 posts

Correct Reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile
jbrar
Employee

14-09-2019

Looks like something at dispatcher level might be causing the issue. Can you change the dispatcher log level to DEBUG and try to load the page?

It should show you all the requests and what might be causing the extra request.

Avatar

Avatar
Validate 10
Level 3
_SumitSinghal
Level 3

Likes

5 likes

Total Posts

79 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 10
Level 3
_SumitSinghal
Level 3

Likes

5 likes

Total Posts

79 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile
_SumitSinghal
Level 3

16-09-2019

I looked at the dispatcher log and found every request is made to the render and file getting cached under htdocs successfully.

I don't see any request which monitor the duplicacy of the file being request and not to serve.

Even no error in the log file

Avatar

Avatar
Boost 5
Level 2
PriyankaBiswal
Level 2

Likes

8 likes

Total Posts

11 posts

Correct Reply

2 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Boost 5
Level 2
PriyankaBiswal
Level 2

Likes

8 likes

Total Posts

11 posts

Correct Reply

2 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Affirm 1
View profile
PriyankaBiswal
Level 2

18-09-2019

Hello,

As category 2 is already  loaded in the page, can you not remove the dependancy of category 2 from component's clientlib and see how it goes.

Avatar

Avatar
Validate 1
MVP
ArpitVarshney
MVP

Likes

135 likes

Total Posts

185 posts

Correct Reply

36 solutions
Top badges earned
Validate 1
Establish
Give Back 5
Give Back 3
Give Back 25
View profile

Avatar
Validate 1
MVP
ArpitVarshney
MVP

Likes

135 likes

Total Posts

185 posts

Correct Reply

36 solutions
Top badges earned
Validate 1
Establish
Give Back 5
Give Back 3
Give Back 25
View profile
ArpitVarshney
MVP

18-09-2019

Hi Sumit,

Yes,Ideally it should be loaded once on dispatcher as well.

There is some issue at the dispatcher only.Could you just clear the dispatcher cache of that page and give it another try?

Regards,

Arpit Varshney

Avatar

Avatar
Validate 10
Level 3
_SumitSinghal
Level 3

Likes

5 likes

Total Posts

79 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 10
Level 3
_SumitSinghal
Level 3

Likes

5 likes

Total Posts

79 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile
_SumitSinghal
Level 3

30-09-2019

Hey,

I already tried , but the issue is the variables which are used getting undefined error in the JS. As the JS loaded at the bottom of the page and the dependency is not able to find the variable above.

Thanks

Avatar

Avatar
Validate 10
Level 3
_SumitSinghal
Level 3

Likes

5 likes

Total Posts

79 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 10
Level 3
_SumitSinghal
Level 3

Likes

5 likes

Total Posts

79 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile
_SumitSinghal
Level 3

30-09-2019

Hi,

Its not the dispatcher which is caching, I have clear the cache and still its not working.

Do you know think ,if any xyz component on parsys contains clientlibs and same clientlibs present at the template also can make the issue.?