Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

ClientLibs loaded twice on the Page

Avatar

Level 4

Hi Team,

I have scenario for  clientlibs  loaded twice on the page

On Template Level :

Example :

categories = [Category1]

dependencies = [category2,category3]

On Component :

categories = [Category4]

dependencies = [category2]

While on page load, I see dependencies are loaded twice using domain abc.com but loaded only once on author and publisher instance which is really strange.

Thanks

8 Replies

Avatar

Employee

Can you clarify when this happens ? When opening the page ?

Avatar

Level 4

Yes on page opening .

When I checked view page source the clientlibs are loaded twice on the page .

Avatar

Employee Advisor

Looks like something at dispatcher level might be causing the issue. Can you change the dispatcher log level to DEBUG and try to load the page?

It should show you all the requests and what might be causing the extra request.

Avatar

Level 4

I looked at the dispatcher log and found every request is made to the render and file getting cached under htdocs successfully.

I don't see any request which monitor the duplicacy of the file being request and not to serve.

Even no error in the log file

Avatar

Level 2

Hello,

As category 2 is already  loaded in the page, can you not remove the dependancy of category 2 from component's clientlib and see how it goes.

Avatar

Level 4

Hey,

I already tried , but the issue is the variables which are used getting undefined error in the JS. As the JS loaded at the bottom of the page and the dependency is not able to find the variable above.

Thanks

Avatar

Community Advisor

Hi Sumit,

Yes,Ideally it should be loaded once on dispatcher as well.

There is some issue at the dispatcher only.Could you just clear the dispatcher cache of that page and give it another try?

Regards,

Arpit Varshney

Avatar

Level 4

Hi,

Its not the dispatcher which is caching, I have clear the cache and still its not working.

Do you know think ,if any xyz component on parsys contains clientlibs and same clientlibs present at the template also can make the issue.?