Highlighted

Clientlibs issue in AEM 6.5

shwethar9638050

06-09-2019

Hi Team,

Recently we are migrating to 6.5 before we have all css and js files in etc/clientlibs,

Now adobe recommended to keep in apps

We have Css/js files under /apps/exampleproject/clientlibs/exampleproject/clientlibs_webtrends this path

The description for the above path

  • exampleproject ->projectname
  • clientlibs (nt:floder) -> Folder
  • exampleproject -> cq:Page
  • clientlibs_webtrends -> cq:ClientLibraryFolder added allowProxy =true

I have set the allowProxy=true to clientlibs_webtrends,    but am not able to expose the clientlibs by

/etc.clientlibs/exampleproject/clientlibs/exampleproject/clientlibs_webtrends/js/example.js

I can access the clientlibs using /apps/exampleproject/clientlibs/exampleproject/clientlibs_webtrends/js/example.js

We cant provide access to /apps in production

Please help me in resolving this issue

Replies

Highlighted

shwethar9638050

06-09-2019

Hi ,

Thanks for the link

I have the same structure as mentioned in the link

Not able to access clientlibs via /etc.clientlibs path as shown in this example

etc.clientlibs/initialyzer/clientlibs/clientlib-base.js

Highlighted

Umesh_Sondhi

MVP

06-09-2019

you have to set the allowProxy property on clientlib-base to true....

then you can request /etc.clientlibs/initialyzer/clientlibs/clientlib-base.js

and i hope you are taking care of this point too

Make sure to use a relative path in place of absolute paths.

Highlighted

shwethar9638050

06-09-2019

In some places we need only one js file to be included, not complete js folder , we are using like below

<script type="text/javascript" src="/etc.clientlibs/initialyzer/clientlibs/initialyzer/clientlib-base/js/example.js"> </script>

but JS file is not loading

Highlighted

Umesh_Sondhi

MVP

06-09-2019

please enable the minify option and then I'd suggest looking at the log file. Sometimes this can happen if there is a syntax error in your JavaScript which is caught by the minimizer.

Highlighted

jbrar

Employee

06-09-2019

Is this issue only observed via dispatcher? If yes, you need to allow etc.clientlibs in the filter rules.

If trying this directly on AEM instance, Setting allowproxy variable should load the clientlib directly on AEM instance using etc.clinetlibs.

Do you see the same issue when using sly? Example:

data-sly-call="${clientlib.js @ categories='clientlib1'}"

Lastly, Can you share the HTML Library Manager configuration from OSGI config manager?

Highlighted

shwethar9638050

08-09-2019

The issue is not only in dispatcher even in local or dev or stage same issue exist

we are using like this

<script language="javascript1.2" src="/etc.clientlibs/example/clientlibs/example/rwd/clientlibs_base_new/js/monitoring.js"></script>

Even after adding allowProxy =true for clientlibs_base its not loading

How can we use this ?

The configmgr screenshota s shown below:

1829843_pastedImage_2.png

1829844_pastedImage_3.png

1829845_pastedImage_4.png