Highlighted

Change password is not working

Niveshchandra

30-06-2020

Hi,

 

Change password is not working on the homepage. After password expiry am getting new fields to enter new password and reenter password. After submitting the form it is showing popup as password changed successfully. But password is not changing. Could any one please help on this issue.

 

Thanks in advance.

Login Login page security User Management

Replies

Highlighted

vanegi

Employee

30-06-2020

Are you changing the password on the homescreen, before logged in into AEM? Do you see any logging in error.log file for this time?

Highlighted

vijis31358935

30-06-2020

Hi @Niveshchandra,

Could you please elaborate on the change password functionality.

Is it a custom component that you have developed?

If yes, backend mechanism for handling the same.

Highlighted

tatvam

30-06-2020

When you say homepage, this is AEM Admin page?

 

Or is the homepage part of the site you built on AEM?

 

In any case, for such errors, you need to troubleshoot, starting with the logs.

Highlighted

Niveshchandra

30-06-2020

Hi Tatvam, Thanks for the response. It is AEM login page provided by adobe only. Not getting any errors in logs and in console
Highlighted

Niveshchandra

30-06-2020

Hi,

Thanks for the response,

It is not custom component, if the user password the expires aem have password change functionality in login page. So one my account password got expired and trying to change the password. Able to get the message like password got changed successfully but password is not changed.

Highlighted

vijis31358935

30-06-2020

Hi @Niveshchandra,

Given that you are getting success message and no errors in log file, Could you please close all working browser window and try to login to the instance(with updated password) in Incognito.

Ignore if you have already tried it.

Highlighted

Nirmal_Jose

MVP

30-06-2020

I have faced this issue in 6.2 when the password was not matching the password policies. Please try with a simple password adhering to to the standards, some special character may be the culprit. You can verify it by logging in into AEM with a different user and then trying to change via user administration console.

 

If you can't login with any user, then its a problem with the AEM instance and you need to check the logs to understand what has gone wrong.

Highlighted

Arun_Patidar

MVP

30-06-2020

Please check “Apache Jackrabbit
Oak Authorizable ActionProvider” OSGi Config from Felix console to check the password policy.