Expand my Community achievements bar.

SOLVED

build images failed on cloud stage deployment

Avatar

Level 4

Hi Team,

Please help me on the below issue while stage deployment.

No issue on dev deployment - aem release - 2022.9.8630.20220905T184657Z 

 

"Unexpected child node getinitiator found in a new node. Caused by org.apache.jackrabbit.oak.api.CommitFailedException: OakConstraint0025: /apps/cq/core[[nt:folder]]: Unexpected child node getinitiator found in a new node"

aem release: 2023.2.11289.20230224T170559Z

 

thank you!

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

The probable causes are listed in this document, for issues at the building image phase :

https://experienceleague.adobe.com/docs/experience-manager-learn/cloud-service/debugging/debugging-a... 

It could be due to 
1. Duplicate OSGi configurations

2. Malformed repoinit

3. Core component's version.

4. Redundant embeds

Just incase, make sure of these by the time Adobe replies.

 

4 Replies

Avatar

Community Advisor

Hi @Lakshmi9 ,

I don't think we would have control anything from our code base to have control over it. Probably your concerned Adobe team should help with this. Can you raise a ticket to the Adobe team?
Thank you.

 

-Sravan

Avatar

Community Advisor

Seems like this was resolved with the newer version of oak. can you check this thread?
https://github.com/adamcin/oakpal/issues/7 


Avatar

Correct answer by
Community Advisor

The probable causes are listed in this document, for issues at the building image phase :

https://experienceleague.adobe.com/docs/experience-manager-learn/cloud-service/debugging/debugging-a... 

It could be due to 
1. Duplicate OSGi configurations

2. Malformed repoinit

3. Core component's version.

4. Redundant embeds

Just incase, make sure of these by the time Adobe replies.

 

page footer