Highlighted

Blank pages on loading home

aembytes

09-10-2017

Out of the blue, our CQ instance is loading blank pages and showing this error. I am assuming this means some of the workflows are missing expected values? We tried clearing entire workflow queue. Do we need to remove workflows from any var folders for this to start loading?

AbstractHTMLRequestInjector

09.10.2017 22:24:26.318 *ERROR* [10.11.0.64 [1507602266111] GET /sites.html/content/freestyle-cms HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingException

java.lang.NullPointerException: null

at com.adobe.granite.workflow.core.status.WorkflowStatusImpl.isInRunningWorkflow(WorkflowStatusImpl.java:49)

at org.apache.jsp.apps.cq.gui.components.siteadmin.admin.pagecard.pagecard_jsp.getWorkItems(pagecard_jsp.java:131)

at org.apache.jsp.apps.cq.gui.components.siteadmin.admin.pagecard.pagecard_jsp._jspService(pagecard_jsp.java:452)

at org.apache.sling.scripting.jsp.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:725)

at org.apache.sling.scripting.jsp.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:502)

at org.apache.sling.scripting.jsp.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:449)

at org.apache.sling.scripting.jsp.JspScriptEngineFactory.callJsp(JspScriptEngineFactory.java:284)

at org.apache.sling.scripting.jsp.JspScriptEngineFactory.access$100(JspScriptEngineFactory.java:102)

at org.apache.sling.scripting.jsp.JspScriptEngineFactory$JspScriptEngine.eval(JspScriptEngineFactory.java:536)

at org.apache.sling.scripting.core.impl.DefaultSlingScript.call(DefaultSlingScript.java:361)

at org.apache.sling.scripting.core.impl.DefaultSlingScript.eval(DefaultSlingScript.java:171)

at org.apache.sling.scripting.core.impl.DefaultSlingScript.service(DefaultSlingScript.java:463)

Replies