Highlighted

Asset share email link not working on Adobe Experience Manager (6.5.0)

Avatar

Avatar

arunkumar_1989

Avatar

arunkumar_1989

arunkumar_1989

27-04-2020

We're in DAM project,So when ever we need to share the asset in mail with in organisation,we received mail but the link was showing like null pointer exeception,Here we using asset share commons 1.8.0 version,Previously this project is in 6.3 version.This issue started from migration to 6.5.0forum.JPG

 

Replies

Highlighted

Avatar

Avatar

Suraj_Kamdi

MVP

Avatar

Suraj_Kamdi

MVP

Suraj_Kamdi
MVP

28-04-2020

Hello @arunkumar_1989 

First of all, you need to use an Externalizer Service to append your production/current domain name with page URL.

Here is the best document from adobe

https://docs.adobe.com/content/help/en/experience-manager-64/developing/platform/externalizer.html

 

Hope this will help. Please let me know if you need more help on this

Thanks & Regard,

Suraj Kamdi

 

 

Highlighted

Avatar

Avatar

arunkumar_1989

Avatar

arunkumar_1989

arunkumar_1989

28-04-2020

Hello @Suraj_Kamdi

Thanks for your response...,

We already configured and append the Externalizer Service to append domain name with page URL,Still we're unable to fix this issue.Here is more about error log.

-------------------------------------------------------------------------------------------------**------------------------------------------------------------------------------------------------------

03.05.2020 18:34:37.670 *WARN* [0:0:0:0:0:0:0:1 [1588511077643] POST /content/dam/core-components-examples.adhocassetshare.html HTTP/1.1] org.apache.jackrabbit.oak.security.authorization.accesscontrol.AccessControlManagerImpl Attempt to create an ACE for an administrative principal which always has full access:/var/dam/share/05db94c0_08fb_441c_9a1e_ebea9a18fb8c
03.05.2020 18:34:37.963 *WARN* [0:0:0:0:0:0:0:1 [1588511077933] POST /content/dam/core-components-examples.adhocassetshare.html HTTP/1.1] org.apache.jackrabbit.oak.security.authorization.accesscontrol.AccessControlManagerImpl Attempt to create an ACE for an administrative principal which always has full access:/var/dam/share/96852378_563a_48c4_9eee_de7650de6adf
03.05.2020 18:34:40.001 *INFO* [CommitStats] CommitStats 20 commits by 2 users [90% admin, 10% assetlinkshareservice] from 3 locations [85% service:jetty, 10% HTTP-POST:/content/dam/core-components-examples.adhocass..., 5% HTTP-GET:/content/dam/core-components-examples.folderthu...] [CommitStats overhead was 91ms = 4550.0us / commit]
03.05.2020 18:34:41.800 *INFO* [sling-default-3-health-org.apache.sling.discovery.oak.SynchronizedClocksHealthCheck] org.apache.sling.discovery.oak.SynchronizedClocksHealthCheck execute: no topology connectors connected to local instance.
03.05.2020 18:34:46.744 *ERROR* [qtp932843553-74] org.apache.felix.http.jetty Exception while processing request to /linkshare.html (java.lang.NullPointerException)
java.lang.NullPointerException: null
at org.apache.jackrabbit.oak.jcr.session.SessionImpl.getAttribute(SessionImpl.java:256) [org.apache.jackrabbit.oak-jcr:1.10.6]