Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

AEM site-admin issue when vanity URL on a page is the path of another page.

Avatar

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile
subramanyav7745
Level 2

18-08-2017

Hi all,

I have this problem on site admin of AEM 6.0-author with SP-3. AEM allows me a page to be vanity URL of another page. Explained below.

On the page http://localhost:4502/siteadmin#/content/geometrixx-outdoors/en/brand/meet-our-ambassadors.html

I have added these Vanity URLs :

/content/geometrixx-outdoors/en/toolbar

/content/geometrixx-outdoors/en/toolbar/about-us

/content/geometrixx-outdoors/en/toolbar/privacy-policy

/content/geometrixx-outdoors/en/toolbar/terms-of-use

/content/geometrixx-outdoors/en/toolbar/search

/content/geometrixx-outdoors/en/toolbar/offline

These vanity URLs are working properly on publish after activating the page http://localhost:4502/siteadmin#/content/geometrixx-outdoors/en/brand/meet-our-ambassadors.html

Now the issue is on author where on site admin. When I click the page on left rail of the page /content/geometrixx-outdoors/en/toolbar I not getting the child page of that page /content/geometrixx-outdoors/en/toolbar on the right side of siteadmin, instead I am getting the child pages of :/content/geometrixx-outdoors/en/brand/meet-our-ambassadors

Even though on the left side I am correctly getting the child pages

Replies

Avatar

Avatar
Validate 1
Level 7
Prince_Shivhare
Level 7

Likes

97 likes

Total Posts

378 posts

Correct Reply

61 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 50
View profile

Avatar
Validate 1
Level 7
Prince_Shivhare
Level 7

Likes

97 likes

Total Posts

378 posts

Correct Reply

61 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 50
View profile
Prince_Shivhare
Level 7

18-08-2017

Hi,

I don't think there is connection of left rail and your vanity URL.

Vanity URL is something for redirecting the page.

~ Prince

Avatar

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile
subramanyav7745
Level 2

21-08-2017

@Prince

I think you have not understood the problem fully.

Here are the steps to reproduce

1)      Install the Vanity-URL-Test Package.

2)      Navigate to Geometrixx-outdoors->English->Men->Coats page in site admin.

3)      Right click and Open the page properties of ‘Product PageTemplate’ page.

4)      In Basic tab, we have configured two vanity urls. First one is existing page such as ‘/content/geometrixx-outdoors/en/company’ which is available under Geometrixx-outdoors->English page.

Second one is non existing page which is ‘/support’ But we have a support page under Geometrixx-outdoors->English page as well, But we haven’t configure the full path.

5)      Since we have configured the existing ‘company’ as a vanity url for ‘product’ page, While clicking of company page on left-side panel in site admin, We are able to see none of the child pages of company page is not displaying on right-side panel of site admin.

Avatar

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile
subramanyav7745
Level 2

21-08-2017

1283012_pastedImage_0.png

Avatar

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile
subramanyav7745
Level 2

21-08-2017

The above screen shot clearly shows the error on Classic Siteadmin# page. I am unable to upload the package that can be used to reproduce the issue. Is there a way to upload?

Avatar

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile
subramanyav7745
Level 2

21-08-2017

One important observation I have made is : On site admin screen the UI is making two ajax calls

1.First AJAX to the page under consideration.

2. Second ajax call to the path which is mentioned under vanity URL.

Avatar

Avatar
Validate 1
Level 3
poojac35931336
Level 3

Likes

20 likes

Total Posts

50 posts

Correct Reply

8 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
poojac35931336
Level 3

Likes

20 likes

Total Posts

50 posts

Correct Reply

8 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
poojac35931336
Level 3

21-08-2017

If you'll check at http://localhost:4502/system/console/jcrresolver?msg=JcrNodeResource%2C+type%3Dcq%3APage%2C+superTyp...

resource getting resolved for "/content/geometrixx-outdoors/en/toolbar" is  "/content/geometrixx-outdoors/en/brand/meet-our-ambassadors" . So it's listing the child pages of "/content/geometrixx-outdoors/en/brand/meet-our-ambassadors" only in right side panel of siteadmin.

Avatar

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile
subramanyav7745
Level 2

21-08-2017

@Pooja: Your explanation is correct.

But I wanted to know why Vanity URL path is getting resolved for a page on site admin?

This incorrect resource resolution happens only when existing  page-path is added as Vanity URL of some other page.

This is incorrect behavior on site admin and needs a fix.

This is affecting our production badly and we need a fix/work around .

Can someone provide the fix or work around.

Is there any documentation that says an existing  page-path should not be added as Vanity-URL of another page? I need adobe documentation so that we can intimate the authors accordingly based on Adobe-documentation.

Thanks,

Subramanya.VL

Avatar

Avatar
Validate 1
Level 3
poojac35931336
Level 3

Likes

20 likes

Total Posts

50 posts

Correct Reply

8 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
poojac35931336
Level 3

Likes

20 likes

Total Posts

50 posts

Correct Reply

8 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
poojac35931336
Level 3

21-08-2017

Instead of vanity URL, you can try redirect "/content/geometrixx-outdoors/en/toolbar" to  "/content/geometrixx-outdoors/en/brand/meet-our-ambassadors" . This way list of child pages won't get affected.

Another work around can be author "/content/geometrixx-outdoors/en/toolbar"  same as  "/content/geometrixx-outdoors/en/brand/meet-our-ambassadors" , this way URL won't change too.

Avatar

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile

Avatar
Give Back 10
Level 2
subramanyav7745
Level 2

Like

1 like

Total Posts

36 posts

Correct Reply

0 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Ignite 10
View profile
subramanyav7745
Level 2

21-08-2017

@Pooja: Thanks for your inputs on redirection.

The advantage with Vanity URL is that we have many Vanity URLs on a single page.

We can have only one redirect using 301/302 on the page.

This is the limitation of using redirects on page.

One more important functionality is that Vanity URL is the input to a page(incoming URL) where as redirection is an outgoing URL for the site.

There is a basic difference : Vanity URL is what you provide and Redirection is what you get from AEM. since both functionalities are different , we could not use it in our requirement.

One more important thing about Vanity-URL is that can be mapped as many to one( means single page has many Vanity URLs).

Why I am calling this as a bug because , the vanity URLs are functioning as expected on the page where we have configured these , but we have the unwanted effect on Site-Admin screen due to the bug.

Hence I need the fix/work-around for the siteadmin page and not for the Vanity URL functionality since it is working as expected on site.