AEM local will not let me edit templates as admin

Avatar

Avatar

JAWillis

Avatar

JAWillis

JAWillis

31-03-2021

After installing AEM on my local and setting up a project/site, when trying to edit a template/page the content tree is empty and there is no content areas on the page so am unable to edit any pages.

Have confirmed that admin has full access and all permissions are set. Cannot seem to find what could be blocking the editable function on AEM 6.5?

Thank you.

admin Content tree Templates

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

kautuk_sahni

Community Manager

Total Posts

6.0K

Likes

1.1K

Correct Reply

1.1K

Avatar

kautuk_sahni

Community Manager

Total Posts

6.0K

Likes

1.1K

Correct Reply

1.1K
kautuk_sahni
Community Manager

01-04-2021

Reply from @JAWillis :

Thank you for your feedback, issue has been resolved, turns out the AEM Service Package for 6.5 was missing.

Answers (5)

Answers (5)

Avatar

Avatar

Arun_Patidar

MVP

Total Posts

3.1K

Likes

1.2K

Correct Reply

879

Avatar

Arun_Patidar

MVP

Total Posts

3.1K

Likes

1.2K

Correct Reply

879
Arun_Patidar
MVP

31-03-2021

can you do view as publish for a page?  it seems there is an issue with page component.

Avatar

Avatar

Bhuwan_B

Avatar

Bhuwan_B

Bhuwan_B

31-03-2021

@JAWillis : Can you please refer below articles and check if you followed all steps while creating Template for your project.

http://www.sgaemsolutions.com/2017/09/dynamic-editable-templates-in-aem-63.html

http://www.sgaemsolutions.com/2017/09/dynamic-editable-templates-in-aem63.html

 

Avatar

Avatar

jbrar

Employee

Avatar

jbrar

Employee

jbrar
Employee

31-03-2021

Share the error from error.log you get when trying to delete the template, Might be related to a content specific issue.

Avatar

Avatar

JAWillis

Avatar

JAWillis

JAWillis

31-03-2021

Please see screenshots below:

When is editing Templates:
Screenshot 2021-03-31 at 13.38.57.png

When in Page edit mode:
Screenshot 2021-03-31 at 13.40.58.png
There does not seem to be any default components coming through:

Screenshot 2021-03-31 at 13.42.28.png
And admin permissions:
Screenshot 2021-03-31 at 13.44.33.png

 

Thank you

Avatar

Avatar

asutosh_j3

Avatar

asutosh_j3

asutosh_j3

31-03-2021

Hi @JAWillis 

Can you please share some screeshots what error you are getting?

Is it a template or on a page?

 

Thanks!