Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.
SOLVED

AEM 6 Maven Repository

Avatar

Level 1

Hi guys,

I am really lost with this task, I am configuring the maven project and Maven cannot resolve the dependencies.

Could someone share the repository information for the AEM 6 libraries?

I could not find the next dependencies:

 

    <dependency>     <groupId>com.adobe.cq.sightly</groupId>     <artifactId>cq-wcm-sightly-extension</artifactId>     <version>1.1.18</version>     </dependency>     <dependency>      <groupId>com.day.cq.wcm</groupId> <artifactId>cq-wcm-api</artifactId> <version>5.8.2</version>     </dependency>

Thank you.

- Miguel.

1 Accepted Solution

Avatar

Correct answer by
Level 1

In case you haven't found a solution for this problem yet, Garbiel gave a solution that worked for me at http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manage....

View solution in original post

4 Replies

Avatar

Correct answer by
Level 1

In case you haven't found a solution for this problem yet, Garbiel gave a solution that worked for me at http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manage....

Avatar

Level 6

Have you added the Adobe Repository in your configuration or in your local Nexus?

 

(http://repo.adobe.com/nexus/content/groups/public/)

 

/Ove

Avatar

Level 1

Hi Ove,

Thanks for the answer, yes I have configured the Adobe Repository in my configuration, but the thing is if you go to that Maven Repository, there are not presented the jar versions used in AEM 6, and there are not the new jars.

For Example:

  • The artefact: com.adobe.cq.sightly.cq-wcm-sightly-extension is not presented.
  • The artefact: com.day.cq.wcm.cq-wcm-api version 5.8.2 is not presented, the latest version in the repository is the 5.7.2 and AEM 6 is using the 5.8.2.

I am looking for the repository for this is exist. At the moment I am including in my project the jars downloaded from my AEM Server, but I would like to configure properly in the Maven configuration.

- Miguel 

Avatar

Level 7

Miguel,

We have found some Maven dependencies for AEM6 have not been made publicly available via the Adobe Repo at the time of release (e.g. aemfd-client-sdk jar ). Reach out via Day care (if you have it) or your partner support and they should find out from the teams whether what you want is actually available yet. My guess is if you cant see it in the repo browser then it hasn't been released yet.

Darren