Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM 6.5 Server is not starting

Avatar

Level 1

Hi All,

 

Recently I am trying to set up AEM 6.5 version in my local but it throwing ERROR: Bundle '16' Error starting slinginstall while setting up my environment. I am using OpenJDK11. Requesting for help.

Below is my stderr file: 

Low-memory action set to fork
Using 64bit VM settings, min.heap=1024MB, min permgen=256MB, default fork arguments=[-Xmx1024m, -XX:MaxPermSize=256m]
The JVM reports a heap size of 2028 MB, meets our expectation of 1024 MB +/- 20
Setting properties from filename 'D:/AEM6.5/Author/cq-author-p4502.jar'
Option '-quickstart.server.port' set to '4502' from filename cq-author-p4502.jar
Passwords do not match.
Passwords do not match.
Passwords do not match.
Passwords do not match.
Verbose option not active, closing stdin and redirecting stdout and stderr
Redirecting stdout to D:\AEM6.5\Author\crx-quickstart\logs\stdout.log
Redirecting stderr to D:\AEM6.5\Author\crx-quickstart\logs\stderr.log
ResourceProvider paths=[/gui, /gui/default]
22.06.2022 12:03:33.648 *ERROR* [FelixStartLevel] ERROR: Bundle '12' Error starting slinginstall:D:\AEM6.5\Author\crx-quickstart\launchpad\startup\1\org.apache.sling.installer.core-3.8.12.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.core [12](R 12.0): missing requirement [org.apache.sling.installer.core [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.sling.installer.core [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.core [12](R 12.0): missing requirement [org.apache.sling.installer.core [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.sling.installer.core [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4149)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2119)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1373)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:829)
22.06.2022 12:03:33.654 *ERROR* [FelixStartLevel] ERROR: Bundle '13' Error starting slinginstall:D:\AEM6.5\Author\crx-quickstart\launchpad\startup\1\org.apache.sling.installer.factory.configuration-1.1.2.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.factory.configuration [13](R 13.0): missing requirement [org.apache.sling.installer.factory.configuration [13](R 13.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.tasks)(version>=1.3.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [12](R 12.0): missing requirement [org.apache.sling.installer.core [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)] Unresolved requirements: [[org.apache.sling.installer.factory.configuration [13](R 13.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.tasks)(version>=1.3.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.factory.configuration [13](R 13.0): missing requirement [org.apache.sling.installer.factory.configuration [13](R 13.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.tasks)(version>=1.3.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [12](R 12.0): missing requirement [org.apache.sling.installer.core [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)] Unresolved requirements: [[org.apache.sling.installer.factory.configuration [13](R 13.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.tasks)(version>=1.3.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4149)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2119)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1373)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:829)
22.06.2022 12:03:33.659 *ERROR* [FelixStartLevel] ERROR: Bundle '14' Error starting slinginstall:D:\AEM6.5\Author\crx-quickstart\launchpad\startup\1\org.apache.sling.installer.provider.file-1.1.0.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.provider.file [14](R 14.0): missing requirement [org.apache.sling.installer.provider.file [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api)(version>=3.1.2)(!(version>=4.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [12](R 12.0): missing requirement [org.apache.sling.installer.core [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)] Unresolved requirements: [[org.apache.sling.installer.provider.file [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api)(version>=3.1.2)(!(version>=4.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.provider.file [14](R 14.0): missing requirement [org.apache.sling.installer.provider.file [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api)(version>=3.1.2)(!(version>=4.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [12](R 12.0): missing requirement [org.apache.sling.installer.core [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)] Unresolved requirements: [[org.apache.sling.installer.provider.file [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api)(version>=3.1.2)(!(version>=4.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4149)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2119)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1373)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:829)
22.06.2022 12:03:33.691 *ERROR* [FelixStartLevel] ERROR: Bundle '16' Error starting slinginstall:D:\AEM6.5\Author\crx-quickstart\launchpad\startup\1\org.apache.sling.launchpad.installer-1.2.2.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.launchpad.installer [16](R 16.0): missing requirement [org.apache.sling.launchpad.installer [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.event)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [12](R 12.0): missing requirement [org.apache.sling.installer.core [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)] Unresolved requirements: [[org.apache.sling.launchpad.installer [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.event)(version>=1.0.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.launchpad.installer [16](R 16.0): missing requirement [org.apache.sling.launchpad.installer [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.event)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [12](R 12.0): missing requirement [org.apache.sling.installer.core [12](R 12.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)] Unresolved requirements: [[org.apache.sling.launchpad.installer [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.event)(version>=1.0.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4149)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2119)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1373)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:829)

 

 

 

1 Reply

Avatar

Administrator

@Giri0669 This seems to me the problem stated: https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/aem-6-2-not-starting-o/m-p...

 // Check if you have JDK and JRE both different installed? 

// /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -version. Uninstall JRE and everything should be fine after that.