Expand my Community achievements bar.

Learn about Edge Delivery Services in upcoming GEM session
SOLVED

AEM 6.2 not starting o

Avatar

Level 3

I'm trying to start an AEM 6.2 instance on a MacOS running JDK 8, 8Gb Ram, 1 Tb HDD. I'm getting the error below in the log files. I've tried deleting the quickstart folder and running install again, doesn't help. I've also tried renaming the file to aem-author-4502.jar, still no progress. Any ideas on what I can do?

Low-memory action set to fork

Using 64bit VM settings, min.heap=1024MB, min permgen=256MB, default fork arguments=[-Xmx1024m, -XX:MaxPermSize=256m]

The JVM reports a heap size of 1024 MB, meets our expectation of 1024 MB +/- 20

No console, will fork to get enough memory

Not forking JVM as -nofork option is set

Setting properties from filename '/Users/Shared/AEM/PROD/aem-author-4502.jar'

Option '-quickstart.server.port' set to '4502' from filename aem-author-4502.jar

Verbose option not active, closing stdin and redirecting stdout and stderr

Redirecting stdout to /Users/Shared/AEM/PROD/crx-quickstart/logs/stdout.log

Redirecting stderr to /Users/Shared/AEM/PROD/crx-quickstart/logs/stderr.log

ResourceProvider paths=[/gui, /gui/default]

loadProperties: found /gui/default/gui.properties

loadProperties: found /gui/gui.properties

getResourceURL: found /gui/cq55icon_round_WIN_512x512.gif

getResourceURL: found /gui/cq55icon_round_WIN_256x256.gif

getResourceURL: found /gui/cq55icon_round_WIN_128x128.gif

getResourceURL: found /gui/cq55icon_round_WIN_64x64.gif

getResourceURL: found /gui/cq55icon_round_WIN_48x48.gif

getResourceURL: found /gui/cq55icon_round_WIN_32x32.gif

getResourceURL: found /gui/cq55icon_round_WIN_16x16_block.gif

getResourceURL: found /gui/gui_bg_start.png

getResourceURL: found /gui/gui_bg_on_blank.png

getResourceURL: found /gui/gui_bg_off.png

org.osgi.framework.BundleException: Exported package names cannot be zero length.

at org.apache.felix.framework.util.manifestparser.ManifestParser.normalizeExportClauses(ManifestParser.java:898)

at org.apache.felix.framework.util.manifestparser.ManifestParser.<init>(ManifestParser.java:216)

at org.apache.felix.framework.ExtensionManager.<init>(ExtensionManager.java:250)

at org.apache.felix.framework.Felix.<init>(Felix.java:429)

at org.apache.sling.launchpad.base.impl.SlingFelix.<init>(SlingFelix.java:49)

at org.apache.sling.launchpad.base.impl.Sling.createFramework(Sling.java:346)

at org.apache.sling.launchpad.base.impl.Sling.<init>(Sling.java:215)

at org.apache.sling.launchpad.base.app.MainDelegate$1.<init>(MainDelegate.java:183)

at org.apache.sling.launchpad.base.app.MainDelegate.start(MainDelegate.java:183)

at org.apache.sling.launchpad.app.Main.doStart(Main.java:411)

at org.apache.sling.launchpad.app.Main.doStart(Main.java:347)

at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.base/java.lang.reflect.Method.invoke(Unknown Source)

at com.adobe.granite.quickstart.base.impl.exec.Bootstrap.run(Bootstrap.java:105)

at com.adobe.granite.quickstart.base.impl.Quickstart.run(Quickstart.java:265)

at com.adobe.granite.quickstart.base.impl.Main.<init>(Main.java:878)

at com.adobe.granite.quickstart.base.impl.Main.main(Main.java:940)

28.05.2018 14:31:42.772 *ERROR* [FelixStartLevel] ERROR: Bundle '1' Error starting slinginstall:com.adobe.granite.startup-0.6.2.jar (org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.startup [1](R 1.0): missing requirement [com.adobe.granite.startup [1](R 1.0)] osgi.wiring.package; (osgi.wiring.package=javax.management) Unresolved requirements: [[com.adobe.granite.startup [1](R 1.0)] osgi.wiring.package; (osgi.wiring.package=javax.management)])

org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.startup [1](R 1.0): missing requirement [com.adobe.granite.startup [1](R 1.0)] osgi.wiring.package; (osgi.wiring.package=javax.management) Unresolved requirements: [[com.adobe.granite.startup [1](R 1.0)] osgi.wiring.package; (osgi.wiring.package=javax.management)]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.773 *ERROR* [FelixStartLevel] ERROR: Bundle '2' Error starting slinginstall:jcl-over-slf4j-1.7.6.jar (org.osgi.framework.BundleException: Unable to resolve jcl.over.slf4j [2](R 2.0): missing requirement [jcl.over.slf4j [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.7.6)) [caused by: Unable to resolve slf4j.api [17](R 17.0): missing requirement [slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))] Unresolved requirements: [[jcl.over.slf4j [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.7.6))])

org.osgi.framework.BundleException: Unable to resolve jcl.over.slf4j [2](R 2.0): missing requirement [jcl.over.slf4j [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.7.6)) [caused by: Unable to resolve slf4j.api [17](R 17.0): missing requirement [slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))] Unresolved requirements: [[jcl.over.slf4j [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.7.6))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.774 *ERROR* [FelixStartLevel] ERROR: Bundle '3' Error starting slinginstall:log4j-over-slf4j-1.7.6.jar (org.osgi.framework.BundleException: Unable to resolve log4j.over.slf4j [3](R 3.0): missing requirement [log4j.over.slf4j [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0)) [caused by: Unable to resolve slf4j.api [17](R 17.0): missing requirement [slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))] Unresolved requirements: [[log4j.over.slf4j [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0))])

org.osgi.framework.BundleException: Unable to resolve log4j.over.slf4j [3](R 3.0): missing requirement [log4j.over.slf4j [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0)) [caused by: Unable to resolve slf4j.api [17](R 17.0): missing requirement [slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))] Unresolved requirements: [[log4j.over.slf4j [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.775 *ERROR* [FelixStartLevel] ERROR: Bundle '4' Error starting slinginstall:org.apache.aries.util-1.1.1.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.aries.util [4](R 4.0): missing requirement [org.apache.aries.util [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.aries.util [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.aries.util [4](R 4.0): missing requirement [org.apache.aries.util [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.aries.util [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.775 *ERROR* [FelixStartLevel] ERROR: Bundle '5' Error starting slinginstall:org.apache.felix.configadmin-1.8.8.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.felix.configadmin [5](R 5.0): missing requirement [org.apache.felix.configadmin [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.felix.configadmin [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.felix.configadmin [5](R 5.0): missing requirement [org.apache.felix.configadmin [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.felix.configadmin [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.776 *ERROR* [FelixStartLevel] ERROR: Bundle '6' Error starting slinginstall:org.apache.felix.coordinator-1.0.2.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.felix.coordinator [6](R 6.0): missing requirement [org.apache.felix.coordinator [6](R 6.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.felix.coordinator [6](R 6.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.felix.coordinator [6](R 6.0): missing requirement [org.apache.felix.coordinator [6](R 6.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.felix.coordinator [6](R 6.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.777 *ERROR* [FelixStartLevel] ERROR: Bundle '7' Error starting slinginstall:org.apache.sling.commons.log-4.0.6.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.log [7](R 7.0): missing requirement [org.apache.sling.commons.log [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.3.0)) Unresolved requirements: [[org.apache.sling.commons.log [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.3.0))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.log [7](R 7.0): missing requirement [org.apache.sling.commons.log [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.3.0)) Unresolved requirements: [[org.apache.sling.commons.log [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.3.0))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.777 *ERROR* [FelixStartLevel] ERROR: Bundle '8' Error starting slinginstall:org.apache.sling.commons.logservice-1.0.6.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.logservice [8](R 8.0): missing requirement [org.apache.sling.commons.logservice [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.commons.logservice [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.logservice [8](R 8.0): missing requirement [org.apache.sling.commons.logservice [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.commons.logservice [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.778 *ERROR* [FelixStartLevel] ERROR: Bundle '11' Error starting slinginstall:org.apache.sling.installer.core-3.6.8.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.core [11](R 11.0): missing requirement [org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0)) Unresolved requirements: [[org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.core [11](R 11.0): missing requirement [org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0)) Unresolved requirements: [[org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.778 *ERROR* [FelixStartLevel] ERROR: Bundle '12' Error starting slinginstall:org.apache.sling.installer.factory.configuration-1.1.2.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.factory.configuration [12](R 12.0): missing requirement [org.apache.sling.installer.factory.configuration [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.tasks)(version>=1.3.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [11](R 11.0): missing requirement [org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0))] Unresolved requirements: [[org.apache.sling.installer.factory.configuration [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.tasks)(version>=1.3.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.factory.configuration [12](R 12.0): missing requirement [org.apache.sling.installer.factory.configuration [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.tasks)(version>=1.3.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [11](R 11.0): missing requirement [org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0))] Unresolved requirements: [[org.apache.sling.installer.factory.configuration [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.tasks)(version>=1.3.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.779 *ERROR* [FelixStartLevel] ERROR: Bundle '13' Error starting slinginstall:org.apache.sling.installer.provider.file-1.1.0.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.provider.file [13](R 13.0): missing requirement [org.apache.sling.installer.provider.file [13](R 13.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.installer.provider.file [13](R 13.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.provider.file [13](R 13.0): missing requirement [org.apache.sling.installer.provider.file [13](R 13.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.installer.provider.file [13](R 13.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.780 *ERROR* [FelixStartLevel] ERROR: Bundle '14' Error starting slinginstall:org.apache.sling.javax.activation-0.1.0.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.javax.activation [14](R 14.0): missing requirement [org.apache.sling.javax.activation [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.javax.activation [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.javax.activation [14](R 14.0): missing requirement [org.apache.sling.javax.activation [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.javax.activation [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.780 *ERROR* [FelixStartLevel] ERROR: Bundle '15' Error starting slinginstall:org.apache.sling.launchpad.installer-1.2.2.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.launchpad.installer [15](R 15.0): missing requirement [org.apache.sling.launchpad.installer [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.event)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [11](R 11.0): missing requirement [org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0))] Unresolved requirements: [[org.apache.sling.launchpad.installer [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.event)(version>=1.0.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.launchpad.installer [15](R 15.0): missing requirement [org.apache.sling.launchpad.installer [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.event)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [11](R 11.0): missing requirement [org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0))] Unresolved requirements: [[org.apache.sling.launchpad.installer [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.event)(version>=1.0.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.781 *ERROR* [FelixStartLevel] ERROR: Bundle '16' Error starting slinginstall:org.apache.sling.settings-1.3.8.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.settings [16](R 16.0): missing requirement [org.apache.sling.settings [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.settings [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.settings [16](R 16.0): missing requirement [org.apache.sling.settings [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.settings [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.781 *ERROR* [FelixStartLevel] ERROR: Bundle '17' Error starting slinginstall:slf4j-api-1.7.6.jar (org.osgi.framework.BundleException: Unable to resolve slf4j.api [17](R 17.0): missing requirement [slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0)) Unresolved requirements: [[slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))])

org.osgi.framework.BundleException: Unable to resolve slf4j.api [17](R 17.0): missing requirement [slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0)) Unresolved requirements: [[slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

1 Accepted Solution

Avatar

Correct answer by
Level 3

I figured out what the problem was. Actually a simple problem. The Mac was running JRE 10 and JDK 8 at the same time. The JDK was the default version so when I checked it using a terminal I got the correct version for AEM. The JRE is installed in a different directory and tied to Internet plugins. So on the MacOS replacing the JDK won't help much, you have to confirm if there's another JRE version running.

To do that type /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -version. Uninstall JRE and everything should be fine after that.

View solution in original post

6 Replies

Avatar

Level 10

Kunwar​ - have you seen this before.

Please post the log error message

Avatar

Employee

what's the error ? Can you post the full error.log

Avatar

Community Advisor

Can you check $JAVA_HOME variable? If path is not set, you'll not able to install aem in MAC.

If you'll set JAVA_HOME path using below it will save path only for this session

  • export JAVA_HOME=/Library/Java/Home
  • echo $JAVA_HOME on Terminal to confirm the path

You need to set path either in .bash_profile or .profile file to persists permanently

How to set JAVA_HOME on Mac OS X - Saje Consultants



Arun Patidar

Avatar

Level 3

This is the error log

Low-memory action set to fork

Using 64bit VM settings, min.heap=1024MB, min permgen=256MB, default fork arguments=[-Xmx1024m, -XX:MaxPermSize=256m]

The JVM reports a heap size of 1024 MB, meets our expectation of 1024 MB +/- 20

No console, will fork to get enough memory

Not forking JVM as -nofork option is set

Setting properties from filename '/Users/Shared/AEM/PROD/aem-author-4502.jar'

Option '-quickstart.server.port' set to '4502' from filename aem-author-4502.jar

Verbose option not active, closing stdin and redirecting stdout and stderr

Redirecting stdout to /Users/Shared/AEM/PROD/crx-quickstart/logs/stdout.log

Redirecting stderr to /Users/Shared/AEM/PROD/crx-quickstart/logs/stderr.log

ResourceProvider paths=[/gui, /gui/default]

loadProperties: found /gui/default/gui.properties

loadProperties: found /gui/gui.properties

getResourceURL: found /gui/cq55icon_round_WIN_512x512.gif

getResourceURL: found /gui/cq55icon_round_WIN_256x256.gif

getResourceURL: found /gui/cq55icon_round_WIN_128x128.gif

getResourceURL: found /gui/cq55icon_round_WIN_64x64.gif

getResourceURL: found /gui/cq55icon_round_WIN_48x48.gif

getResourceURL: found /gui/cq55icon_round_WIN_32x32.gif

getResourceURL: found /gui/cq55icon_round_WIN_16x16_block.gif

getResourceURL: found /gui/gui_bg_start.png

getResourceURL: found /gui/gui_bg_on_blank.png

getResourceURL: found /gui/gui_bg_off.png

org.osgi.framework.BundleException: Exported package names cannot be zero length.

at org.apache.felix.framework.util.manifestparser.ManifestParser.normalizeExportClauses(ManifestParser.java:898)

at org.apache.felix.framework.util.manifestparser.ManifestParser.<init>(ManifestParser.java:216)

at org.apache.felix.framework.ExtensionManager.<init>(ExtensionManager.java:250)

at org.apache.felix.framework.Felix.<init>(Felix.java:429)

at org.apache.sling.launchpad.base.impl.SlingFelix.<init>(SlingFelix.java:49)

at org.apache.sling.launchpad.base.impl.Sling.createFramework(Sling.java:346)

at org.apache.sling.launchpad.base.impl.Sling.<init>(Sling.java:215)

at org.apache.sling.launchpad.base.app.MainDelegate$1.<init>(MainDelegate.java:183)

at org.apache.sling.launchpad.base.app.MainDelegate.start(MainDelegate.java:183)

at org.apache.sling.launchpad.app.Main.doStart(Main.java:411)

at org.apache.sling.launchpad.app.Main.doStart(Main.java:347)

at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.base/java.lang.reflect.Method.invoke(Unknown Source)

at com.adobe.granite.quickstart.base.impl.exec.Bootstrap.run(Bootstrap.java:105)

at com.adobe.granite.quickstart.base.impl.Quickstart.run(Quickstart.java:265)

at com.adobe.granite.quickstart.base.impl.Main.<init>(Main.java:878)

at com.adobe.granite.quickstart.base.impl.Main.main(Main.java:940)

28.05.2018 14:31:42.772 *ERROR* [FelixStartLevel] ERROR: Bundle '1' Error starting slinginstall:com.adobe.granite.startup-0.6.2.jar (org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.startup [1](R 1.0): missing requirement [com.adobe.granite.startup [1](R 1.0)] osgi.wiring.package; (osgi.wiring.package=javax.management) Unresolved requirements: [[com.adobe.granite.startup [1](R 1.0)] osgi.wiring.package; (osgi.wiring.package=javax.management)])

org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.startup [1](R 1.0): missing requirement [com.adobe.granite.startup [1](R 1.0)] osgi.wiring.package; (osgi.wiring.package=javax.management) Unresolved requirements: [[com.adobe.granite.startup [1](R 1.0)] osgi.wiring.package; (osgi.wiring.package=javax.management)]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.773 *ERROR* [FelixStartLevel] ERROR: Bundle '2' Error starting slinginstall:jcl-over-slf4j-1.7.6.jar (org.osgi.framework.BundleException: Unable to resolve jcl.over.slf4j [2](R 2.0): missing requirement [jcl.over.slf4j [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.7.6)) [caused by: Unable to resolve slf4j.api [17](R 17.0): missing requirement [slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))] Unresolved requirements: [[jcl.over.slf4j [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.7.6))])

org.osgi.framework.BundleException: Unable to resolve jcl.over.slf4j [2](R 2.0): missing requirement [jcl.over.slf4j [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.7.6)) [caused by: Unable to resolve slf4j.api [17](R 17.0): missing requirement [slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))] Unresolved requirements: [[jcl.over.slf4j [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.7.6))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.774 *ERROR* [FelixStartLevel] ERROR: Bundle '3' Error starting slinginstall:log4j-over-slf4j-1.7.6.jar (org.osgi.framework.BundleException: Unable to resolve log4j.over.slf4j [3](R 3.0): missing requirement [log4j.over.slf4j [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0)) [caused by: Unable to resolve slf4j.api [17](R 17.0): missing requirement [slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))] Unresolved requirements: [[log4j.over.slf4j [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0))])

org.osgi.framework.BundleException: Unable to resolve log4j.over.slf4j [3](R 3.0): missing requirement [log4j.over.slf4j [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0)) [caused by: Unable to resolve slf4j.api [17](R 17.0): missing requirement [slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))] Unresolved requirements: [[log4j.over.slf4j [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.helpers)(version>=1.6.0))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.775 *ERROR* [FelixStartLevel] ERROR: Bundle '4' Error starting slinginstall:org.apache.aries.util-1.1.1.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.aries.util [4](R 4.0): missing requirement [org.apache.aries.util [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.aries.util [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.aries.util [4](R 4.0): missing requirement [org.apache.aries.util [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.aries.util [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.775 *ERROR* [FelixStartLevel] ERROR: Bundle '5' Error starting slinginstall:org.apache.felix.configadmin-1.8.8.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.felix.configadmin [5](R 5.0): missing requirement [org.apache.felix.configadmin [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.felix.configadmin [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.felix.configadmin [5](R 5.0): missing requirement [org.apache.felix.configadmin [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.felix.configadmin [5](R 5.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.776 *ERROR* [FelixStartLevel] ERROR: Bundle '6' Error starting slinginstall:org.apache.felix.coordinator-1.0.2.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.felix.coordinator [6](R 6.0): missing requirement [org.apache.felix.coordinator [6](R 6.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.felix.coordinator [6](R 6.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.felix.coordinator [6](R 6.0): missing requirement [org.apache.felix.coordinator [6](R 6.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.felix.coordinator [6](R 6.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.777 *ERROR* [FelixStartLevel] ERROR: Bundle '7' Error starting slinginstall:org.apache.sling.commons.log-4.0.6.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.log [7](R 7.0): missing requirement [org.apache.sling.commons.log [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.3.0)) Unresolved requirements: [[org.apache.sling.commons.log [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.3.0))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.log [7](R 7.0): missing requirement [org.apache.sling.commons.log [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.3.0)) Unresolved requirements: [[org.apache.sling.commons.log [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.3.0))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.777 *ERROR* [FelixStartLevel] ERROR: Bundle '8' Error starting slinginstall:org.apache.sling.commons.logservice-1.0.6.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.logservice [8](R 8.0): missing requirement [org.apache.sling.commons.logservice [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.commons.logservice [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.logservice [8](R 8.0): missing requirement [org.apache.sling.commons.logservice [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.commons.logservice [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.778 *ERROR* [FelixStartLevel] ERROR: Bundle '11' Error starting slinginstall:org.apache.sling.installer.core-3.6.8.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.core [11](R 11.0): missing requirement [org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0)) Unresolved requirements: [[org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.core [11](R 11.0): missing requirement [org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0)) Unresolved requirements: [[org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.778 *ERROR* [FelixStartLevel] ERROR: Bundle '12' Error starting slinginstall:org.apache.sling.installer.factory.configuration-1.1.2.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.factory.configuration [12](R 12.0): missing requirement [org.apache.sling.installer.factory.configuration [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.tasks)(version>=1.3.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [11](R 11.0): missing requirement [org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0))] Unresolved requirements: [[org.apache.sling.installer.factory.configuration [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.tasks)(version>=1.3.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.factory.configuration [12](R 12.0): missing requirement [org.apache.sling.installer.factory.configuration [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.tasks)(version>=1.3.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [11](R 11.0): missing requirement [org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0))] Unresolved requirements: [[org.apache.sling.installer.factory.configuration [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.tasks)(version>=1.3.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.779 *ERROR* [FelixStartLevel] ERROR: Bundle '13' Error starting slinginstall:org.apache.sling.installer.provider.file-1.1.0.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.provider.file [13](R 13.0): missing requirement [org.apache.sling.installer.provider.file [13](R 13.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.installer.provider.file [13](R 13.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.provider.file [13](R 13.0): missing requirement [org.apache.sling.installer.provider.file [13](R 13.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.installer.provider.file [13](R 13.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.780 *ERROR* [FelixStartLevel] ERROR: Bundle '14' Error starting slinginstall:org.apache.sling.javax.activation-0.1.0.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.javax.activation [14](R 14.0): missing requirement [org.apache.sling.javax.activation [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.javax.activation [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.javax.activation [14](R 14.0): missing requirement [org.apache.sling.javax.activation [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.javax.activation [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.780 *ERROR* [FelixStartLevel] ERROR: Bundle '15' Error starting slinginstall:org.apache.sling.launchpad.installer-1.2.2.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.launchpad.installer [15](R 15.0): missing requirement [org.apache.sling.launchpad.installer [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.event)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [11](R 11.0): missing requirement [org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0))] Unresolved requirements: [[org.apache.sling.launchpad.installer [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.event)(version>=1.0.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.launchpad.installer [15](R 15.0): missing requirement [org.apache.sling.launchpad.installer [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.event)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.installer.core [11](R 11.0): missing requirement [org.apache.sling.installer.core [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(version<=2.0.0))] Unresolved requirements: [[org.apache.sling.launchpad.installer [15](R 15.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.installer.api.event)(version>=1.0.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.781 *ERROR* [FelixStartLevel] ERROR: Bundle '16' Error starting slinginstall:org.apache.sling.settings-1.3.8.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.settings [16](R 16.0): missing requirement [org.apache.sling.settings [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.settings [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))])

org.osgi.framework.BundleException: Unable to resolve org.apache.sling.settings [16](R 16.0): missing requirement [org.apache.sling.settings [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[org.apache.sling.settings [16](R 16.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

28.05.2018 14:31:42.781 *ERROR* [FelixStartLevel] ERROR: Bundle '17' Error starting slinginstall:slf4j-api-1.7.6.jar (org.osgi.framework.BundleException: Unable to resolve slf4j.api [17](R 17.0): missing requirement [slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0)) Unresolved requirements: [[slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))])

org.osgi.framework.BundleException: Unable to resolve slf4j.api [17](R 17.0): missing requirement [slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0)) Unresolved requirements: [[slf4j.api [17](R 17.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.3.0))]

at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)

at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)

at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)

at java.base/java.lang.Thread.run(Unknown Source)

Avatar

Level 3

I've checked and double checked the JAVA_HOME path, its fine. I've switched from jdk1.8 to jdk 1.7, no difference. Totally stumped

Avatar

Correct answer by
Level 3

I figured out what the problem was. Actually a simple problem. The Mac was running JRE 10 and JDK 8 at the same time. The JDK was the default version so when I checked it using a terminal I got the correct version for AEM. The JRE is installed in a different directory and tied to Internet plugins. So on the MacOS replacing the JDK won't help much, you have to confirm if there's another JRE version running.

To do that type /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -version. Uninstall JRE and everything should be fine after that.