Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM 6.4: Products not visible after upgrade to 6.4

Elkish
Level 2
Level 2

We are having an issue with the products entered into the commerce system in AEM 6.4.  After upgrading from 6.3, I migrated our products to the new JCR location under /var/commerce based on the release notes.  While the folders themselves are now visible when navigating the products page , none of the products themselves appear in any of the directories.

Specifically, what appears to be happening is that calls to

http://localhost:4502/mnt/overlay/granite/ui/content/tree.0.html/var/commerce/products/examples?colu...

Will return the following, even if there are products in the /var/commerce/products/examples path:

{"items": [],"hasMore": false}

Notably, this only happens if we install 6.4 using the -r nosamplecontent parameter.  Navigating products works fine if the sample content is installed (but has problems with nested multifields due to the sample content registering a sling model for the /commerce/component/products resource type.)

Steps to reproduce:

1 - Create a fresh install of AEM 6.4 Using the "-r nosamplecontent" parameter

2 - Create a sling folder "example" under /var/commerce/products

3 - Create a product node under /var/commerce/products/example

4 - Navigate to http://localhost:4502/libs/commerce/gui/content/products.html/var/commerce/products/example

Expected: The product should be visible

Result: No product is visible

Does anyone know why the default install for 6.4 would prevent products from being visible in the commerce system?

2 Replies
smacdonald2008
Level 10
Level 10

Checking with Support team to see if this is a known upgrade issue.

smacdonald2008
Level 10
Level 10

Our customer care team replied --

"I think that a migration approach is not supported. It must be an in place upgrade "

Elkish
Level 2
Level 2

Our product data was relocated based on the following documentation from Adobe:

Adobe Experience Manager Help | E-Commerce Repository Restructuring in AEM 6.4

Additionally the examples present in the sample content had been moved to /var/commerce/products as well.  The problem persists on a fresh AEM install.  Replicating the issue is as simple as trying to create a product in an instance of 6.4 without the sample content installed - I can provide a package with an example product if needed.

smacdonald2008
Level 10
Level 10

If you have followed this Adobe doc and its not working - there could be a bug somewhere. Instructions from an Adobe doc should work. 

I advice opening a support ticket so our customer care team can report this bug so its fixed.

Elkish
Level 2
Level 2

After filing a ticket with Adobe support, the issue appears to be that code critical to making the e-commerce forms work is actually only available in the sample content.  It would be possible to to do a custom build of the sample content with just the code needed to make E-Commerce work correctly, however, based on how brittle the whole system is our team has chosen to store our product data another way.