Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM 6.3 Desktop app 1.5.0.3 crashes with unexpected error every time I login

Avatar

Level 1

AEM 6.3 Desktop app 1.5.0.3 crashes with unexpected error every time I attempt to login. I can put in the IP to the instance and get the login screen, but once I put in my login info and click login I briefly see a spinner then the app crashes. This happens when I try to hit my local, and when I try to go to instances running on a server. I have tried both windows versions (x86 and x64) on windows 7. Any help or pointers into how to get this to stop erroring and get it working would be appreciated.

Log files say some interesting things:

aemcompanionlog.txt

2017-08-03 10:42:40,250 [1] INFO AemCompanion.Program - Starting notification panel application

2017-08-03 10:42:42,682 [4] INFO AemCompanion.NodeBackend - [JS]: AEM Assets Companion add-on initialized.

2017-08-03 10:42:42,683 [4] INFO AemCompanion.NodeBackend - [JS]: Using backend configuration file at C:\Program Files (x86)\Adobe\Adobe Experience Manager Desktop\javascript\config.json

2017-08-03 10:42:43,841 [1] INFO AemCompanion.ProcessIcon - Left mouse click, displaying context menu

2017-08-03 10:42:47,615 [1] INFO AemCompanion.Program - Starting notification panel application

2017-08-03 10:42:50,068 [4] INFO AemCompanion.NodeBackend - [JS]: AEM Assets Companion add-on initialized.

2017-08-03 10:42:50,069 [4] INFO AemCompanion.NodeBackend - [JS]: Using backend configuration file at C:\Program Files (x86)\Adobe\Adobe Experience Manager Desktop\javascript\config.json

2017-08-03 10:42:50,286 [1] INFO AemCompanion.ProcessIcon - Left mouse click, displaying context menu

2017-08-03 10:57:14,438 [1] INFO AemCompanion.ProcessIcon - Left mouse click, displaying context menu

2017-08-03 10:57:25,455 [4] INFO AemCompanion.NodeBackend - [JS]: server start deferred with options: {"url":"http://localhost:4502","cacheRoot":"C:/Users/abradshaw/AppData/Local/Adobe/AssetsCompanion/Cache/http%3a%2f%2flocalhost%3a4502%2faem%2fstart.html"}

2017-08-03 10:57:26,005 [4] INFO AemCompanion.NodeBackend - [JS]: Config: {"domainName":"","allowAnonymous":false,"extendedSecurity":false,"users":{"admin":{"lmHash":"f0d412bd764ffe81aad3b435b51404ee","ntlmHash":"209c6174da490caeb422f3fa5a7ae634"}},"dav":{"debug":false,"host":"localhost","backend":"DAM","path":"C:\\Users\\abradshaw\\AppData\\Local\\Adobe\\AssetsCompanion\\Cache\\http%3a%2f%2flocalhost%3a4502%2faem%2fstart.html\\smbcacheroot"},"shares":{"DAM":{"backend":"rqb","description":"AEM Assets RQ Share","maxSockets":32,"contentCacheTTL":30000,"binCacheTTL":600000,"expiration":30000,"frequency":3000,"maxRetries":3,"retryDelay":10000,"modifiedThreshold":100,"noUnicodeNormalize":true,"local":{"backend":"fs","description":"fs test share local","noUnicodeNormalize":true,"path":"C:\\Users\\abradshaw\\AppData\\Local\\Adobe\\AssetsCompanion\\Cache\\http%3a%2f%2flocalhost%3a4502%2faem%2fstart.html\\smbcacheroot/cache/content/dam"},"work":{"backend":"fs","description":"fs test share work","noUnicodeNormalize":true,"path":"C:\\Users\\abradshaw\\AppData\\Local\\Adobe\\AssetsCompanion\\Cache\\http%3a%2f%2flocalhost%3a4502%2faem%2fstart.html\\smbcachework"},"events":["syncfilestart","syncfileend","syncfileerr","syncfileprogress","syncerr","syncpurged","syncconflict","folderlist","requestqueueinit"],"preserveCacheFiles":["request-queue.nedb","upload-status.nedb"],"log":{"_stdout":{"level":0,"name":"stdout","_writableState":{"objectMode":false,"highWaterMark":16384,"needDrain":false,"ending":false,"ended":false,"finished":false,"decodeStrings":true,"defaultEncoding":"utf8","length":0,"writing":false,"corked":0,"sync":false,"bufferProcessing":false,"writecb":null,"writelen":0,"bufferedRequest":null,"lastBufferedRequest":null,"pendingcb":3,"prefinished":false,"errorEmitted":false,"bufferedRequestCount":0,"corkedRequestsFree":{"next":null,"entry":null}},"writable":true,"domain":null,"_events":{},"_eventsCount":0},"_stderr":{"level":4,"name":"stderr","_writableState":{"objectMode":false,"highWaterMark":16384,"needDrain":false,"ending":false,"ended":false,"finished":false,"decodeStrings":true,"defaultEncoding":"utf8","length":0,"writing":false,"corked":0,"sync":true,"bufferProcessing":false,"writecb":null,"writelen":0,"bufferedRequest":null,"lastBufferedRequest":null,"pendingcb":0,"prefinished":false,"errorEmitted":false,"bufferedRequestCount":0,"corkedRequestsFree":{"next":null,"entry":null}},"writable":true,"domain":null,"_events":{},"_eventsCount":0}},"host":"localhost","port":"4502","path":"/content/dam","protocol":"http:","options":{"headers":{"cookie":"","referer":"http://localhost:4502"}},"tmpPath":"C:\\Users\\abradshaw\\AppData\\Local\\Adobe\\AssetsCompanion\\Cache\\http%3a%2f%2flocalhost%3a4502%2faem%2fstart.html\\smbcacheroot/cache/content/dam"}}}

2017-08-03 10:57:26,152 [4] ERROR AemCompanion.NodeBackend - [JS]: error while attempting to start server SMBError {

  status: 3221225473,

  message: 'Invalid protocol: proxy.micron.com: [invalid share configuration: {"host":"localhost","port":"4502","path":"/content/dam"}]' }

2017-08-03 10:57:26,155 [11] ERROR AemCompanion.ProcessExecutor - Encountered unhandled thread exception

System.Exception

   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

   at AemCompanion.NodeBackend.<Execute>d__31.MoveNext()

--- End of stack trace from previous location where exception was thrown ---

   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

   at CallSite.Target(Closure , CallSite , Object )

   at System.Dynamic.UpdateDelegates.UpdateAndExecute1[T0,TRet](CallSite site, T0 arg0)

   at AemCompanion.Proxy.<>c__DisplayClass52.<<Login>b__51>d__54.MoveNext()

--- End of stack trace from previous location where exception was thrown ---

   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

   at AemCompanion.ProcessExecutor.<>c__DisplayClass1.<<AwaitThenCall>b__0>d__3.MoveNext()

2017-08-03 10:57:26,160 [4] WARN AemCompanion.NodeBackend - [JS]: unable to retrieve companioninfo due to unexpected status code 401

2017-08-03 10:57:26,163 [11] ERROR AemCompanion.Program - Encountered an unhandled exception.

System.Exception

   at AemCompanion.ProcessExecutor.<>c__DisplayClass1.<<AwaitThenCall>b__0>d__3.MoveNext()

--- End of stack trace from previous location where exception was thrown ---

   at System.Runtime.CompilerServices.AsyncMethodBuilderCore.<>c.<ThrowAsync>b__6_1(Object state)

   at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)

   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)

   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)

   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()

   at System.Threading.ThreadPoolWorkQueue.Dispatch()

   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

server.log

2017-08-03T16:42:48.710Z - info: logging initialized.

2017-08-03T16:57:26.135Z - info: Mounted jsDav server. root=C:\Users\abradshaw\AppData\Local\Adobe\AssetsCompanion\Cache\http%3a%2f%2flocalhost%3a4502%2faem%2fstart.html\smbcacheroot

2017-08-03T16:57:26.140Z - info: Webdav server started and listening on port 59635

2017-08-03T16:57:26.151Z - error: unable to connect tree DAM status=3221225473, message=Invalid protocol: proxy.micron.com: [invalid share configuration: {"host":"localhost","port":"4502","path":"/content/dam"}]

spi.log

2017-08-03T16:57:26.149Z - error: invalid share configuration: {"host":"localhost","port":"4502","path":"/content/dam"} Error: Invalid protocol: proxy.micron.com:

    at Request.init (C:\Program Files (x86)\Adobe\Adobe Experience Manager Desktop\javascript\node_modules\node-smb-server\node_modules\request\request.js:460:31)

    at new Request (C:\Program Files (x86)\Adobe\Adobe Experience Manager Desktop\javascript\node_modules\node-smb-server\node_modules\request\request.js:130:8)

    at request (C:\Program Files (x86)\Adobe\Adobe Experience Manager Desktop\javascript\node_modules\node-smb-server\node_modules\request\index.js:54:10)

    at Object.submitRequest (C:\Program Files (x86)\Adobe\Adobe Experience Manager Desktop\javascript\node_modules\node-smb-server\lib\webutils.js:40:10)

    at RQRemoteShare.DAMShare.fetchContent (C:\Program Files (x86)\Adobe\Adobe Experience Manager Desktop\javascript\node_modules\node-smb-server\lib\backends\dam\share.js:100:12)

    at RQRemoteShare.JCRShare.getContent (C:\Program Files (x86)\Adobe\Adobe Experience Manager Desktop\javascript\node_modules\node-smb-server\lib\backends\jcr\share.js:130:8)

    at getContent (C:\Program Files (x86)\Adobe\Adobe Experience Manager Desktop\javascript\node_modules\node-smb-server\lib\backends\jcr\share.js:436:10)

    at fn (C:\Program Files (x86)\Adobe\Adobe Experience Manager Desktop\javascript\node_modules\async\lib\async.js:746:34)

    at C:\Program Files (x86)\Adobe\Adobe Experience Manager Desktop\javascript\node_modules\async\lib\async.js:1213:16

    at C:\Program Files (x86)\Adobe\Adobe Experience Manager Desktop\javascript\node_modules\async\lib\async.js:166:37

6 Replies

Avatar

Level 10

Has this always happened or after you installed a new package?

Avatar

Level 1

We are upgrading to 6.3 so when we were on 6.1 with the old desktop app it worked fine. We have one instance of 6.3 with our 6.1 content and code, but we also have an instance that is 6.3 out of the box, my local is OOB as well and the desktop app crashes.

Avatar

Level 10

This looks like a bug - please open a ticket so eng can fix this.

Avatar

Level 1

Hey - Was there a solution to this please? I face the same error on 6.3

Avatar

Level 1

Hello Sir - No, this one is even for a fresh 6.3 not an upgrade.

My use case is not exactly same but I was looking for solution around connection drops.

Mine is - After successfully logging in to the app, when you move any folder within the mounted drive, it does not move the folder and Connection drops consistently (for file movement it works fine). On windows also similar, just that we dont see message of Connection dropped - the folder doesnt move and the mounted drive is disconnected.