Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.1 Sightly: org.apache.sling.scripting.sightly.impl.engine.extension.use.UseRuntimeExtension No use provider could resolve identifier

Akanksha_Pratih
Level 2
Level 2

Hi

 

I'm just trying to call a simple wcmUsePojo class implementation from an aem component, but while doing so I'm getting below given error:

org.apache.sling.scripting.sightly.impl.engine.extension.use.UseRuntimeExtension No use provider could resolve identifier "myClassName".

The code is very simple and does not contain any complex stuff yet, still its not working. the  bundle is active and the pojo class package is also available in exported packages.

The code snipped is as given below:

<div data-sly-use.navigationUtilTest="${'com.dummy.helper.navigationUtilTest'}" data-sly-unwrap>
        Dummy Text

</div>

1 Accepted Solution
Akanksha_Pratih
Correct answer by
Level 2
Level 2

Got the solution, my class name started with lower case letter just changed it to upper case and it worked.

View solution in original post

0 Replies
smacdonald2008
Level 10
Level 10

Looks like there is an issue wirh the Java. See this community article to get up and running:  https://helpx.adobe.com/experience-manager/using/creating-sightly-component.html

Akanksha_Pratih
Correct answer by
Level 2
Level 2

Got the solution, my class name started with lower case letter just changed it to upper case and it worked.

View solution in original post