Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

AEM 6.0 and AC 6.1.1 Integration Problem

Avatar

Level 1

Hi All,

I'm working on integrating AC 6.1.1 with AEM 6.0, following this link http://docs.adobe.com/docs/en/aem/6-0/administer/integration/marketing-cloud/campaign.html#Configuri... an external AEM account Everything works fine until I want to synchronize content from AC.  When I hit the button "synchronize" the dialog pops up and displays the following error:

An error occurred while loading the list.Error detail

Error while executing the method 'aemListContent' of service 'nms:delivery'. 

Further detail message says the following:

Error while compiling script 'nms:amcIntegration.js' line 1599: JSON.parse.

I've been able to see that the underlying code performs a request (query) to the following resource in AEM that doesn't exist :

 'http://myserver:4052/api/content/sites/campaigns.json?'

I suspect that I'm missing some package or bundle in AEM but so far I haven't found anything that could point me in the right direction to solve this issue.

Can anyone tell me anything that could be a possible solution to this?

Thanks in advance.

Henry.

1 Accepted Solution

Avatar

Correct answer by
Level 10

From package share install the feature pack FeaturePack-5515. If you are not finding the feature pack please file a official support ticket.

View solution in original post

3 Replies

Avatar

Correct answer by
Level 10

From package share install the feature pack FeaturePack-5515. If you are not finding the feature pack please file a official support ticket.

Avatar

Level 4

Hi,

Is this applicable feature pack installation applicable for integrating AEM 6.1 with AC 6.1 also? We are facing similar error but I don't see any mention of installing such feature pack as a prerequisite in AEM 6.1 installation document.

Regards,

Anil

Avatar

Level 1

I have an official ticket about this and I am wondering if I have a similar issue.  I am running AEM 6.3 though.  I am trying to synchronize the old geomettrix newsletter.  I looked for the feature pack described above "FeaturePack-5515" but I don't see it, and plus I'm not sure it still applies to AEM 6.3.  Adobe any suggestions?