Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 5.6.1 Inbox link Defect

NitroHazeDev
Level 7
Level 7

Hello,

We have a task in the inbox, and as i see in AEM 5.6.1, on click of the link under "Content" column (as provided in snapshot attached),  I see the link being 

1. http://localhost:4502/bin/wcmcommand?cmd=open&path=%252Fcontent%252Fcampaigns%252......

Instead of

2. http://localhost:4502/content/campaigns/.....

This occurs in 5.6.1 instance Only and not in 5.6. 

As a result when i click on the incorrect link that AEM provides,[1] above, we get a 404, page not found error.

Can someone please confirm if this is a defect.

Regards,

Nicole

1 Accepted Solution
smacdonald2008
Correct answer by
Level 10
Level 10

This is a known bug and is reported in the AEM bug base. 

View solution in original post

7 Replies
smacdonald2008
Correct answer by
Level 10
Level 10

This is a known bug and is reported in the AEM bug base. 

View solution in original post

DarrenBiz
Level 7
Level 7

Can you tell us the bug report number or the patch that we need to apply to fix this please?

Sham_HC
Level 10
Level 10

DarrenBiz wrote...

Can you tell us the bug report number or the patch that we need to apply to fix this please?

 

CQ5-34572 . Overlay [1] & change url to

var url = CQ.HTTP.externalize(CQ.shared.XSS.getXSSValue(value));

[1]   /libs/cq/workflow/widgets/source/utils/InboxUtil.js

vesankar
Level 1
Level 1
This issue still pops-up even in AEM 6.5 even though the abovementioned line fix is present
DarrenBiz
Level 7
Level 7

Thanks Sham. Is there an official hotfix for this fix?