Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Replies

Avatar

Avatar
Validate 1
Level 3
trc41594544
Level 3

Likes

16 likes

Total Posts

43 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile

Avatar
Validate 1
Level 3
trc41594544
Level 3

Likes

16 likes

Total Posts

43 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
trc41594544
Level 3

28-07-2020

Yes, i have checked that. It is present in the execution paths.

Avatar

Avatar
Validate 1
Level 3
trc41594544
Level 3

Likes

16 likes

Total Posts

43 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile

Avatar
Validate 1
Level 3
trc41594544
Level 3

Likes

16 likes

Total Posts

43 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
trc41594544
Level 3

28-07-2020

The whole problem is that it is not coming in to AEM at all. I cannot see the request coming through in access.log. I could have figured out if there is a error in error log but i dont see it in access logs it self. If i access anything else other than /services/ i can see the request in access logs .

Avatar

Avatar
Validate 1
Level 3
trc41594544
Level 3

Likes

16 likes

Total Posts

43 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile

Avatar
Validate 1
Level 3
trc41594544
Level 3

Likes

16 likes

Total Posts

43 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
trc41594544
Level 3

28-07-2020

As this is author, there is no disptacher and there is nothing in front of our author instance. I am accessing the instance directly.

Avatar

Avatar
Give Back 5
Employee
sunjot16
Employee

Likes

104 likes

Total Posts

164 posts

Correct Reply

50 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 25
Give Back 10
Give Back
View profile

Avatar
Give Back 5
Employee
sunjot16
Employee

Likes

104 likes

Total Posts

164 posts

Correct Reply

50 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 25
Give Back 10
Give Back
View profile
sunjot16
Employee

28-07-2020

Can you please enable DEBUG logging for error.log loggers and see whether you get any requests for custom servlet in error.log file?

Avatar

Avatar
Establish
MVP
ChitraMadan
MVP

Likes

227 likes

Total Posts

124 posts

Correct Reply

50 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Establish
MVP
ChitraMadan
MVP

Likes

227 likes

Total Posts

124 posts

Correct Reply

50 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
ChitraMadan
MVP

28-07-2020

Hi @trc41594544 ,

 


Can you please check if your servlet is active here

http://localhost:4502/system/console/components

Avatar

Avatar
Validate 1
Level 3
trc41594544
Level 3

Likes

16 likes

Total Posts

43 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile

Avatar
Validate 1
Level 3
trc41594544
Level 3

Likes

16 likes

Total Posts

43 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
trc41594544
Level 3

28-07-2020

Yes, it is active and it is even resolving as expected when tried in /system/console/servletresolver .

Avatar

Avatar
Establish
MVP
BrianKasingli
MVP

Likes

611 likes

Total Posts

588 posts

Correct Reply

230 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile

Avatar
Establish
MVP
BrianKasingli
MVP

Likes

611 likes

Total Posts

588 posts

Correct Reply

230 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile
BrianKasingli
MVP

28-07-2020

@trc41594544., please check the Apache Sling Servlet/Script Resolver and Error Handler configuration, /system/console/configMgr/org.apache.sling.servlets.resolver.SlingServletResolver. Ensure that the /services/ path is present. 

Note: If a configured value ends with a slash, the whole sub tree is allowed. Without a slash an exact matching script is allowed. (servletresolver.paths)

Screenshot 2020-07-28 at 21.46.21.png

Avatar

Avatar
Validate 1
Level 3
trc41594544
Level 3

Likes

16 likes

Total Posts

43 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile

Avatar
Validate 1
Level 3
trc41594544
Level 3

Likes

16 likes

Total Posts

43 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 5
View profile
trc41594544
Level 3

28-07-2020

Thats not the problem. i can see services in execution paths. We have /services/ present in the execution paths.