Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Access issue for etc in AEM 6.4

Avatar

Level 2

Hi, Is it mandatory to give access to everyone group to the /etc/designs explicitly in AEM 6.4? We have compressed clientLibs under etc/designs and they are not loading in publishers without giving access to everyone group in /etc.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

That is called as "anonymous"/unauthenticated access to content. There is a user with the name "anonymous" in publish server to whom you need to assign appropriate read permissions either on the user itself or via its associated group which is 'everyone' in this case.

Anonymous access is required for /content & /etc paths for the app to work. Make sure to limit down the read access to specific paths.

View solution in original post

0 Replies

Avatar

Community Advisor

With what user did you try to access the content? That user should have appropriate read permissions (assigned to the user directly or via its group) to access the content.

Please provide more information on what did you access, what permissions did you provide in case you can't figure it out.

Avatar

Level 2

I am trying to access the page in publisher environment without login into publisher.i.e everyone group.

Avatar

Correct answer by
Community Advisor

That is called as "anonymous"/unauthenticated access to content. There is a user with the name "anonymous" in publish server to whom you need to assign appropriate read permissions either on the user itself or via its associated group which is 'everyone' in this case.

Anonymous access is required for /content & /etc paths for the app to work. Make sure to limit down the read access to specific paths.

Avatar

Level 2

Is it same with 6.2..? Same pages are loading without giving access in 6.2

Avatar

Community Advisor

It is the same behavior for all AEM versions.

If it works fine w/o providing read access then you may check "sling authentication service" configurations under "/system/console/configMgr" to validate that you have "-/etc/<something>" 

minus sign is to allow anonymous access

plus sign is to enforce to authentication

1712413_pastedImage_1.png