Expand my Community achievements bar.

Elevate your expertise and be recognized as a true influencer! Nominations for the exclusive Adobe Community Advisor program 2023 are now OPEN.
SOLVED

A problem with Author and Publish instances installed as two window services in the same machine.

Avatar

Not applicable

This question was originally asked in a comment on the page http://dev.day.com/docs/en/cq/current/deploying/installing_cq.html#Installing and Starting Adobe Experience Manager as a Windows Service.

But we are having the same trouble and there does not seem to be a solution.

We have Author and Publish instances are installed as two window services in the same machine.
However, It cannot start author and publish services at the same time.
We can only ever start one of them and not both.

It is possible to start two instances by clicking the quick start jars but the services fail with this error in the startup.log....

2013-11-25 16:40:12 Commons Daemon procrun stdout initialized

2013-11-25 16:40:12 Commons Daemon procrun stderr initialized

25.11.2013 16:40:12.693 *INFO * [main] Setting sling.home=. (command line)

25.11.2013 16:40:12.701 *INFO * [main] Sent 'status' to /127.0.0.1:63000: ERR: wrong key

25.11.2013 16:40:12.702 *ERROR* [main] Sling already active in C:\development\adobeCQ\publish\crx-quickstart\.

We have one instance in "C:\development\adobeCQ\publish" and the other in "C:\development\adobeCQ\author". We have one on port 4502 and the other on 4503.  

We wondered if the issue was related to the log entry "/127.0.0.1:63000" but we do not know what should be done.

Please advise.

1 Accepted Solution

Avatar

Correct answer by
Level 10

There is variable cq_ctrlport in the instsrv.bat file. You need to modify it for one of the instance.

  • Modifed the cq_ctrlport to different port
  • uninstalled the service
  • ran instsrv.bat.
0 Replies

Avatar

Correct answer by
Level 10

There is variable cq_ctrlport in the instsrv.bat file. You need to modify it for one of the instance.

  • Modifed the cq_ctrlport to different port
  • uninstalled the service
  • ran instsrv.bat.

Avatar

Level 10

I will work with the documentation team to make sure we get these instructions into the main AEM documentation. Thanks for the answer Sham! 

Avatar

Level 1

The port number also exists in the file crx-quickstart/conf/controlport.  It only worked for me once I'd changed the value in both this file and instsrv.bat and replaced the service.

Avatar

Level 1

In AEM 6.2, the file prunsrv_amd64.exe is missing in the standalone OSGi quickstart installation. 

Had to copy it from an older 6.1 instance for a customer.

Avatar

Level 2

I am facing the same issue in a linux server. The AEM server is not getting started with the ./start command and there is no error in the error.log and stdout.log files. The only error I see in stdout.log file is "*ERROR* [main] Sling already active in /mnt/crx/publish/crx-quickstart". Any suggestions to resolve it?