Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Workflow send email variables

Avatar

Level 5

I upgraded from AEM 6.4 to 6.5 as well as with forms, I had a workflow package that I created in 6.4 and it did not have the dropdown for a variable. now they wont work. can you please tell me how do I go about fixing this workflow?

1822317_pastedImage_0.png

1 Accepted Solution

Avatar

Correct answer by
Level 5

workflowuser

the deprecated one worked..... jummmm… you guys need to fix the new one.

1822686_pastedImage_0.png

View solution in original post

11 Replies

Avatar

Employee

So the email subject can be a variable or a literal

in your It is going to be literal

Avatar

Level 5

what do I need to do please it wont let me choose anything there isn't anything to choose. what if I don't want to use a variable. it wont let me save the workflow. I chose a literal and as you can see it says "EOIR 26 submission" but it still wants me to choose a variable

Avatar

Employee

Or just drag a new send email component and configure its settings again

Avatar

Employee

Try creating a new workflow and see if itnis any different with send email component

Avatar

Correct answer by
Level 5

workflowuser

the deprecated one worked..... jummmm… you guys need to fix the new one.

1822686_pastedImage_0.png

Avatar

Employee

In your case you have to select literal from the drop down list for the email subject and type in value

if you are selecting metadata then you should have created a metadata property by that name which I do not think is the case

Avatar

Level 5

workflowuser​ look at the picture I have chosen literal and then the variable drop down shows up. so I am chosing what made it work. then the system is even more buggy than I thought.

1822687_pastedImage_0.png

Avatar

Level 5

workflowuser​ it is working now. I have solve the issue. no further help needed. the deprecated one work as I stated above. I will try the new one once I see the drop down menu for variables do not show up again. I guess there should be an update. the pictures above shows you the problem