Render Error on Submit

Avatar

Avatar
Validate 1
Level 2
alexandrad27705
Level 2

Likes

2 likes

Total Posts

19 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
alexandrad27705
Level 2

Likes

2 likes

Total Posts

19 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
alexandrad27705
Level 2

03-04-2016

Hi, 

I have an adaptive form which I have been working on for some time. I also have a XDP base template to generate the DoR. My form has the "store PDF action" configured and generating the DoR has worked fine for some time now. All of the sudden I am getting errors when submitting the form and don't know what is going wrong because the entire stack trace is pointing towards AEM classes.

04.04.2016 15:55:50.892 *ERROR* [0:0:0:0:0:0:0:1 [1459749350227] POST /content/forms/af/my-company/my-form/jcr:content/guideContainer.af.submit.jsp HTTP/1.1] com.day.cq.wcm.core.impl.WCMDebugFilter Exception: null
com.adobe.aemds.guide.service.GuideException: null
    at com.adobe.aemds.guide.servlet.GuideSubmitServlet.doPost(GuideSubmitServlet.java:254)
    at org.apache.sling.api.servlets.SlingAllMethodsServlet.mayService(SlingAllMethodsServlet.java:149)
    at org.apache.sling.api.servlets.SlingSafeMethodsServlet.service(SlingSafeMethodsServlet.java:345)
    at org.apache.sling.api.servlets.SlingSafeMethodsServlet.service(SlingSafeMethodsServlet.java:376)
....
Caused by: com.adobe.aemds.guide.service.GuideException: null
    at com.adobe.aemds.guide.addon.service.impl.GuidePDFSubmitHelperImpl.getWrappedParameterMapForPdfSubmit(GuidePDFSubmitHelperImpl.java:147)
    at com.adobe.aemds.guide.servlet.GuideSubmitServlet.doPost(GuideSubmitServlet.java:155)
    ... 131 common frames omitted
Caused by: com.adobe.forms.service.LCFormsServiceException: null
    at com.adobe.forms.service.impl.LCFormsOsgiServiceImpl.render(LCFormsOsgiServiceImpl.scala:92)
    at com.adobe.forms.service.impl.LCFormsServiceImpl.render(LCFormsServiceImpl.java:79)
    at com.adobe.aemds.guide.addon.service.impl.XFAModelTransformerImpl.getPdfFromXfaDom(XFAModelTransformerImpl.java:176)
    at com.adobe.aemds.guide.addon.service.impl.GuidePDFSubmitHelperImpl.getWrappedParameterMapForPdfSubmit(GuidePDFSubmitHelperImpl.java:112)
    ... 132 common frames omitted
Caused by: java.lang.Exception: PAExecute Failure: XFA_RENDER_FAILURE
    at com.adobe.forms.aem.impl.XFANativeServiceImpl.paExecute(XFANativeServiceImpl.java:162)
    at com.adobe.forms.aem.impl.XFANativeServiceImpl.paExecute(XFANativeServiceImpl.java:430)
    at com.adobe.forms.xtg.impl.XMLFormServiceImpl$$anonfun$paExecute$2$$anonfun$2.apply(XMLFormServiceImpl.scala:167)
    at com.adobe.forms.xtg.impl.XMLFormServiceImpl$$anonfun$paExecute$2$$anonfun$2.apply(XMLFormServiceImpl.scala:167)
....

Can anyone point me in the right direction? How can I find out what is wrong with the form?

Any help is greatly appreciated! Thanks, 

Alex

Replies

Avatar

Avatar
Boost 1
Level 2
nitinn18425437
Level 2

Like

1 like

Total Posts

16 posts

Correct reply

7 solutions
Top badges earned
Boost 1
Affirm 5
Affirm 3
Affirm 1
View profile

Avatar
Boost 1
Level 2
nitinn18425437
Level 2

Like

1 like

Total Posts

16 posts

Correct reply

7 solutions
Top badges earned
Boost 1
Affirm 5
Affirm 3
Affirm 1
View profile
nitinn18425437
Level 2

03-04-2016

Hi Alex,

  It usually means some issue with either XDP, data or fonts. Exact cause of this error is printed just before this exception in logs. If you can share entire error.log file from crx-quickstart/logs/ then we should be able to help in identifying the root cause.

Thanks

Nitin

Avatar

Avatar
Validate 1
Level 2
alexandrad27705
Level 2

Likes

2 likes

Total Posts

19 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
alexandrad27705
Level 2

Likes

2 likes

Total Posts

19 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
alexandrad27705
Level 2

04-04-2016

Hi Nitin, 

Thanks for your quick response!

I've attached more of the error.log. There is something with "The SOM expression '$record.Accomomodation[*]' for the dataRef specified on field 'Accomomodation', resolved to an incompatible node type of 'dataValue'." Not sure if this is the problem and what it means. Accommodation is a repeatable panel which should be rendered as a table in the DoR...But I haven't made any changes to that, so not sure if this is really the problem. 

Any help is very appreciated because I don't have the time to start all over with the form!

Thanks, Alex

Avatar

Avatar
Validate 1
Level 2
alexandrad27705
Level 2

Likes

2 likes

Total Posts

19 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
alexandrad27705
Level 2

Likes

2 likes

Total Posts

19 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
alexandrad27705
Level 2

04-04-2016

Update:

I found the issue why there is an error when generating the DoR: I have a checkbox at the beginning of the form which shows/hides a child panel (Accommodation) of the form. If this panel is hidden (and the Form has "Exclude fields from DoR if hidden" checked) it comes up with the error: "The SOM expression '$record.Accomomodation[*]' for the dataRef specified on field 'row', resolved to an incompatible node type of 'dataValue' "

I've tried setting the visibility of the fields in that panel to false when the panel's visibility is false but that doesn't make a difference. 

Has anyone come across this? Is there a way to fix this?

Thanks, Alex

Avatar

Avatar
Boost 1
Level 2
sachjain
Level 2

Like

1 like

Total Posts

11 posts

Correct reply

2 solutions
Top badges earned
Boost 1
Affirm 1
View profile

Avatar
Boost 1
Level 2
sachjain
Level 2

Like

1 like

Total Posts

11 posts

Correct reply

2 solutions
Top badges earned
Boost 1
Affirm 1
View profile
sachjain
Level 2

04-04-2016

Hi Alex,

What is the version of Adaptive Form you are using? If you could share Adaptive form and XML Schema to find out the cause of the issue, would be very useful resource to fix the issue.

Thank You,

Sachin Jain

Avatar

Avatar
Boost 1
Level 2
sachjain
Level 2

Like

1 like

Total Posts

11 posts

Correct reply

2 solutions
Top badges earned
Boost 1
Affirm 1
View profile

Avatar
Boost 1
Level 2
sachjain
Level 2

Like

1 like

Total Posts

11 posts

Correct reply

2 solutions
Top badges earned
Boost 1
Affirm 1
View profile
sachjain
Level 2

04-04-2016

One question, are all fields under Accommodation panel bound to attributes i.e. their bind references contain '@'?

Avatar

Avatar
Validate 1
Level 2
alexandrad27705
Level 2

Likes

2 likes

Total Posts

19 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
alexandrad27705
Level 2

Likes

2 likes

Total Posts

19 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
alexandrad27705
Level 2

04-04-2016

Hi Sachjain,

None of my fields in the form are bound and have no bind references. I am using AEM 6.1 Forms (JEE). 

I can package the form and send it to you via email. 

Thanks, 

Alex

Avatar

Avatar
Level 1
gabork51827145
Level 1

Likes

0 likes

Total Posts

2 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
gabork51827145
Level 1

Likes

0 likes

Total Posts

2 posts

Correct reply

0 solutions
View profile
gabork51827145
Level 1

17-10-2017

Hi Alex did you find a solution ? I have a similar problem.

Avatar

Avatar
Validate 1
Level 2
mohamed90
Level 2

Likes

4 likes

Total Posts

35 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back 10
Give Back
View profile

Avatar
Validate 1
Level 2
mohamed90
Level 2

Likes

4 likes

Total Posts

35 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back 10
Give Back
View profile
mohamed90
Level 2

07-01-2019

Ich habe auch den gleichen Fehler . Habt ihr die Losung gefunden

Danke eure Antwort