Expand my Community achievements bar.

Learn about Edge Delivery Services in upcoming GEM session
SOLVED

AEM Forms theme editor doesn't work

Avatar

Level 4

I am using AEM 6.5 with service pack 5 without the forms add-on package. When I create a new form theme and then try to edit it, the theme editor doesn't open the theme for editing, instead it remains on the loading state and downloads a file with name 'jcr_content'. There are no java script errors on the browser console. There were similar questions asked on the community and the recommendation were to make sure all the "**aemds**" and "**aemfd**" packages are in installed state. I did verify this and all the bundles with *aemds* and *aemfd* are in active state. The form editor works fine on AEM 6.5.0.

Could find any errors on the error.log except the log file on the working instance (6.5.0) show these additional lines.
11.04.2023 09:19:45.849 *INFO* [sling-oak-observation-16] com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl detected [CSS] theme library: /etc/clientlibs/fd/themes/my-own-theme-2, sourced from 3 files.
11.04.2023 09:19:45.857 *INFO* [sling-oak-observation-16] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Rebuilt 2214 ancestor paths.

 

Your assistance here is highly appreciated, as it looks like the service packs are causing this issue.

 

P.S: Please note that the tests are done on two fresh instances (6.5.0 and 6.5.5) on the localhost without any custom code on them. Also, with no forms add-on installed.
 

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

The ability to use adaptive forms without the forms add on package is for demo purposes only. To use adaptive forms in your production environment, you have to license AEM Forms

View solution in original post

5 Replies

Avatar

Employee Advisor

@Seek_AEM 

I can replicate the use-case in-house with the latest SP16, but why aren't you using the forms add-on to leverage the forms features (and themes)? How are you applying the themes?

OOTB very elementary Forms features are provided with AEM installation, and you're seeing this issue probably because you don't have the add-on installed.

Avatar

Level 4

Hi @Pulkit_Jain_ @workflowuser The forms add-on comes at a price, and we don't even need all those features forms add-on provides hence we stuck to the basic AEM install as it exactly caters for the basic forms that we create.
We are able to create and use themes with our adaptive forms so far until 6.5.5. I am not sure why we need a forms add-on now to work around some bug that is introduced by one of the service packs. 

Avatar

Correct answer by
Employee Advisor

The ability to use adaptive forms without the forms add on package is for demo purposes only. To use adaptive forms in your production environment, you have to license AEM Forms

Avatar

Level 4

@workflowuser This is news to me, could you point me to the documentation or the release notes of an AEM version since when it has been marked only for demo purposes.