Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

WDB-200011 The requested database record does not exist: Adobe Campaign - empty data record cause error message

AdobeDeveloper1
Level 2
Level 2

Hi All,

I am facing below error while sending the Daily NL ,

I have understood two option from the below error :

1.

As per my understanding : The error message states that there is a missing record in the related table on the other side of relation 'FK'. It seems we have a table inside our database and for this campaign, the foreign key field holds some value.

We need to check if the table has a record with correct primary Kay . If not, try to identify what value this record held and try to add a new record with the same PK.

2. Or there something wrong with the MX rules .

Can some one please help here?

WDB-200001 SQL statement
'SELECT   R0.iRecipientId, R0.sLastName, R0.sFirstName, R0.sEmail, R0.sSalutation, R0.sMiddleName, R0.sAccount, R0.iStatus, R0.sCompany, R0.iGender, R0.sLanguage, R0.tsBirth, R0.iBlackList, R0.iFolderId, R0.iEmailFormat, R0.sMobilePhone, R0.sFax, R0.sPhone, R0.sOrigin, R0.sAddress1, R0.sAddress2, R0.sAddress3, R0.sAddress4, R0.sZipCode, R0.sCity, R0.sCountryCode, R0.sStateCode, AllNonNull3(R0.sZipCode , R0.sCity , R0.sLastName), R0.iAddrErrorCount, R0.iAddrQuality, R0.tsAddrLastCheck, R0.sText1, R0.sText2, R0.sText3, R0.sText4, R0.sText5, R0.iBoolean1, R0.iBoolean2, R0.iBoolean3, F1.sLabel, F1.iFolderId, F1.sFullName, case when 'eng' = 'fra' then C2.sLabelFR else case when 'eng' = 'deu' then C2.sLabelDE else case when 'eng' = 'jpn' then C2.sLabelJA else C2.sLabelEN end end end, C2.sIsoA2, case when 'eng' = 'jpn' then NULL else S3.sCode || ' - ' end || case when 'eng' = 'fra' then S3.sLabelFR else case when 'eng' = 'deu' then S3.sLabelDE else case when 'eng' = 'jpn' then S3.sLabelJA else S3.sLabelEN end end end, S3.sCode, S3.sCountryCode, case when 'eng' = 'fra' then C4.sLabelFR else case when 'eng' = 'deu' then C4.sLabelDE else case when 'eng' = 'jpn' then C4.sLabelJA else C4.sLabelEN end end end, case when 'eng' = 'fra' then C4.sLabelFR else case when 'eng' = 'deu' then C4.sLabelDE else case when 'eng' = 'jpn' then C4.sLabelJA else C4.sLabelEN end end end, C4.sIsoA2, R0.mData FROM NmsRecipient R0 JOIN XtkFolder F1 ON (F1.iFolderId = R0.iFolderId) LEFT JOIN NmsCountry C2 ON (C2.sIsoA2 = R0.sCountryCode) LEFT JOIN NmsState S3 ON (S3.sCode = R0.sStateCode AND S3.sCountryCode = R0.sCountryCode) LEFT JOIN NmsCountry C4 ON (C4.sIsoA2 = S3.sCountryCode) WHERE ((R0.iFolderId IN (SELECT xr.iFolderId FROM XtkRights xr WHERE xr.iOperatorId IN (6762030, 65221)) OR R0.iFolderId=0)) AND (((R0.iFolderId IN (SELECT xr.iFolderId FROM XtkRights xr WHERE xr.iOperatorId IN (6762030, 65221)) OR R0.iFolderId=0)) AND ((R0.iRecipientId = :1)))'

could not be executed.
 
  
 
  09/16/2017 10:41:36 AM Failed Invalid domain  No mx records have been found! Domain: ''; Type: 28; Time used: 0 ms
WDB-200011 The requested database record does not exist

Cannot load document of type 'Recipients (nms:recipient)' satisfying condition '([/@id] = 8545834)'

1 Accepted Solution
Amit_Kumar
Correct answer by
Community Advisor
Community Advisor

Follow given steps to resolve this:

  • Check if you have a recipient with ([/@id] = 8545834) in your database?
  • If yes, what's his email address?
  • Get the user domain from the email address and check if you have this domain in MX rules?
  • If yes, check if it's active?
  • If this rule is active, then check if domain mask is correct.

This Troubleshooting will help you in fixing your problem.

Regards

Amit

View solution in original post

4 Replies
Amit_Kumar
Correct answer by
Community Advisor
Community Advisor

Follow given steps to resolve this:

  • Check if you have a recipient with ([/@id] = 8545834) in your database?
  • If yes, what's his email address?
  • Get the user domain from the email address and check if you have this domain in MX rules?
  • If yes, check if it's active?
  • If this rule is active, then check if domain mask is correct.

This Troubleshooting will help you in fixing your problem.

Regards

Amit

View solution in original post

florentlb
Level 10
Level 10

Hi,

Were you able to resolve your issue as per Amit's suggestions?

Let us know,

Florent

najwanh771343
Level 1
Level 1

Hi,

try to add to the link element in the schema the following attribute:

externalJoin="true"

AdobeDeveloper1
Level 2
Level 2

For us it looks like one of the tracking WF is not configure , and WF has this coded for the tracking , due to this every time we get this error