Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Uploading image is adding wrong height value

jc-yme
Level 1
Level 1

Since the beginning of this week, I noticed that uploading an image using the standard image component is adding an height value that is not always correct.

When creating a blank template and adding 1:1 column structure component with an image , I get the following code.

 

  <body class="">
    <div class="acr-container">
      <div class="acr-structure" data-structure-id="1-1-column" data-structure-name="richtext.structure_1_1_column">
        <table class="structure__table" align="center" cellpadding="0" cellspacing="0" border="0" width="750">
          <tbody>
            <tr>
              <th class="colspan1">
                <div class="acr-fragment acr-component image-container" data-component-id="image" style="width:100%;text-align:center;" contenteditable="false">
                  <!--[if mso]><table cellpadding="0" cellspacing="0" border="0" width="100%"><tr><td style="text-align: center;"><![endif]-->
                  <!--[if mso]></td></tr></table><![endif]-->
                  <div class="component-image-container"></div>
                </div>
              </th>
            </tr>
          </tbody>
        </table>
      </div>
    </div>
  </body>

 


After uploading a test image with following sizes ( 3000px/1100px with 32kb), I get the following code adding an height of 99 (?)

 <div class="acr-container">
      <div class="acr-structure" data-structure-id="1-1-column" data-structure-name="richtext.structure_1_1_column">
        <table class="structure__table" align="center" cellpadding="0" cellspacing="0" border="0" width="750">
          <tbody>
            <tr>
              <th class="colspan1">
                <div class="acr-fragment acr-component image-container" data-component-id="image" style="width:100%;text-align:center;" contenteditable="false">
                  <!--[if mso]><table cellpadding="0" cellspacing="0" border="0" width="100%"><tr><td style="text-align: center;"><![endif]-->
                  <img src="http://res.mailings.yamaha-motor.eu/res/yme_mkt_prod1/4447ce431b7233b56472a7326d2c9b025e75722694286c25fa94b9b39cfbf3ef.jpg" style="width: 100%; height: auto;" height="99">
                  <!--[if mso]></td></tr></table><![endif]-->
                </div>
              </th>
            </tr>
          </tbody>
        </table>
      </div>
    </div>


I tried several images different in ration, image and file image file and get rather random results!
Below is the code after uploading an image which is 16/9 ratio (  1920px/1080px and 328kb in size) - height = 152!

 <div class="acr-container">
      <div class="acr-structure" data-structure-id="1-1-column" data-structure-name="richtext.structure_1_1_column">
        <table class="structure__table" align="center" cellpadding="0" cellspacing="0" border="0" width="750">
          <tbody>
            <tr>
              <th class="colspan1">
                <div class="acr-fragment acr-component image-container" data-component-id="image" style="width:100%;text-align:center;" contenteditable="false">
                  <!--[if mso]><table cellpadding="0" cellspacing="0" border="0" width="100%"><tr><td style="text-align: center;"><![endif]-->
                  <img src="http://res.mailings.yamaha-motor.eu/res/yme_mkt_prod1/352bf94636ab5251bdaf05032627e4a3851f6daec86a2fc6c1587583b2042d0a.jpg" height="152" style="width: 100%; height: auto;">
                  <!--[if mso]></td></tr></table><![endif]-->
                </div>
              </th>
            </tr>
          </tbody>
        </table>
      </div>
    </div>

Does anyone know how to have this height adjusted to image ration used ( ex: I expect last code example to add an height of 422px )?

This height value is discarded by most email clients but MS outlook uses it 😞

1 Accepted Solution
ramon_bisswanger
Correct answer by
Employee
Employee

This seems to be a bug in 20.1 release.

(Was reported by other clients already)

 

Please raise a ticket in the support tool to have it tracked for your customer.

View solution in original post

2 Replies
ramon_bisswanger
Correct answer by
Employee
Employee

This seems to be a bug in 20.1 release.

(Was reported by other clients already)

 

Please raise a ticket in the support tool to have it tracked for your customer.

View solution in original post

knixHaas
Level 2
Level 2
Thank you for waiting and per this release documentation: https://docs.adobe.com/content/help/en/campaign-standard/using/release-notes/release-planning.html Release 20.2.1 is scheduled for March 30 - April 06, 2020.