Javascript logging WebApplication

Avatar

Avatar
Validate 1
Level 2
akshayk23775697
Level 2

Likes

9 likes

Total Posts

11 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
akshayk23775697
Level 2

Likes

9 likes

Total Posts

11 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Affirm 1
View profile
akshayk23775697
Level 2

26-09-2019

Hi

I am new to Campaign and needed some help

1. Our webapplication has a script Action in it.  Within the Script Action there are multiple  logInfo function calls.  The webapplication is working fine but i do not see these LogInfo call logged anywhere.  I tried looking into the Audit section of the webapplication but nothing is logged there. 

2. Are the general log files which Campaign generates. Are they on the file server somewhere?

Thanks

akshay

Replies

Avatar

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

353 likes

Total Posts

464 posts

Correct reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

353 likes

Total Posts

464 posts

Correct reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile
Jean-Serge_Biro
MVP

26-09-2019

Hi Akshay,

The logInfo() logError() messages of webApps and reports are written in the web.log file on the server where the webApps or reports are executed.

On standalone architecture, so you can see it by using the ACC user interface Home>Monitoring>section of Process logs the web.log link.

On standard architecture, the web server is on the MTA so you must connect to it to display the errors.

Regards
J-Serge

Avatar

Avatar
Establish
MVP
wodnicki
MVP

Likes

977 likes

Total Posts

1,096 posts

Correct reply

516 solutions
Top badges earned
Establish
Affirm 500
Contributor
Shape 1
Give Back 100
View profile

Avatar
Establish
MVP
wodnicki
MVP

Likes

977 likes

Total Posts

1,096 posts

Correct reply

516 solutions
Top badges earned
Establish
Affirm 500
Contributor
Shape 1
Give Back 100
View profile
wodnicki
MVP

26-09-2019

Hi,

Check the web module log, in Linux /usr/local/neolane/nl6/var/default/log/web.log.

Also available under the Monitoring tab of the home screen, default@web.

Thanks,

-Jon

Avatar

Avatar
Validate 1
Level 2
akshayk23775697
Level 2

Likes

9 likes

Total Posts

11 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
akshayk23775697
Level 2

Likes

9 likes

Total Posts

11 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Affirm 1
View profile
akshayk23775697
Level 2

13-11-2019

Hi Jean-Serge Biron

The logInfo no longer logs any thing under  Monitoring> Process List > web@default.

Any suggestion what could have gone wrong. It used to work before

thanks

akshay

Avatar

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

353 likes

Total Posts

464 posts

Correct reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Validate 1
MVP
Jean-Serge_Biro
MVP

Likes

353 likes

Total Posts

464 posts

Correct reply

153 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 250
View profile
Jean-Serge_Biro
MVP

13-11-2019

Hi akshay,

Do you mean nothing at all ? the web.log file is totally empty ?
Or the web.log file is not mentioned/service not started?
or the web.log file exists, but it appears empty because you selected an old date and the log rotation has switched to the web_2.log file ? Then after a size limit it is over, the old lines are erased.


So please confirm the date selected from/to, check if you didn't type a char in the filter at the top right of the page, etc.
Or use direct access server to check log files.

Regards
J-Serge