Expand my Community achievements bar.

Join us for Adobe Campaign Community Q&A Coffee Break on Thursday, March 7th at 8am PT with Eric Perrin, Gael Mouello, Chakravarthy Kalva, Bruce Swann and Sandra Hausmann.
SOLVED

Postgresql error while sql execution

Avatar

Level 2

Hi Guys, I'm facing the postgresql error while SQL execution to update the table name. Let me know why i'm facing this error and i can execute the same SQL in V7 and i'm facing the issue while executing the same in V8

 

Haricharan_0-1706512476842.png

 

1 Accepted Solution

Avatar

Correct answer by
Level 6

Hi @Haricharan,

 

To update temp table data in ACC v8 using the above script, you must use the "change data source" activity, and select "default data source" in the activity. Then your script should work fine if there are no other syntax errors.

isahore_0-1706520049589.png

 

Let me know if that helped.

 

BR,

Ishan

View solution in original post

6 Replies

Avatar

Level 7

Hi @Haricharan 

 

The error states that the temp table you are trying to access is invalid, could you check the temp table name by enabling the SQL logs in the properties of the workflow.

Hope this helps!

You can try inserting the value through JavaScript write method also. For reference.

 

Thanks

Akshay

Avatar

Level 2

I have checked the SQL logs and re-run the workflow but the sql logs looks empty.

Haricharan_0-1706518478361.png

 

Avatar

Level 7

Hi @Haricharan 

 

Could you please check if the checkbox is "checked".

AkshayAnand_0-1706520622876.png

 

linking the documentation for reference.

 

Thanks

Akshay

Avatar

Level 2

Yeah yeah the checkbox has been checked!

 But the sql logs are empty

Avatar

Correct answer by
Level 6

Hi @Haricharan,

 

To update temp table data in ACC v8 using the above script, you must use the "change data source" activity, and select "default data source" in the activity. Then your script should work fine if there are no other syntax errors.

isahore_0-1706520049589.png

 

Let me know if that helped.

 

BR,

Ishan

Avatar

Level 2

Hi Ishan,

 

This is working fine but the thing is while using memodescription to populate the table inside the delivery, its not working!

 

But using any other field to populate the value its working!