Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

Unspecified Data in Evar 5

bindukumari1990
Level 4
Level 4

Hi Team,

I have created conversion variable evar5, which identifies the user type like general customers, corporate, employee and other.

But in analysis workspace, for visits metric unspecified is coming around 2K. When I exported the file through data feed, then I got to know for custom link evar 5 is not firing. Even the analysis workspace number says the same.

bindukumari1990_0-1631692594917.png

 

But when checked links in the server call, evar 5 is firing. For exampe urls are:

https://www.whirlpoolindia.com/refrigerators/single-door/icemagic-pro-200l-single-door-refrigerator-...

https://www.whirlpoolindia.com/top-load/whitemagic-elite-7-5-kg-fully-automatic-top-load-washing-mac...

 

Then, what is reason for coming unspecified. Please note it is happening for Product detail page only(PDP Page).

 

5 Replies
amgup
Level 7
Level 7

@bindukumari1990  I checked the website URL and found that evar5 is firing on Page View call only and not when Custom Link call is happening. Can you check if you have passed evar5 in s.linkTrackVars ? 

https://experienceleague.adobe.com/docs/analytics/implementation/vars/config-vars/linktrackvars.html...

evolytics_brian
Community Advisor
Community Advisor

@bindukumari1990- I'm also seeing what @amgup is reporting. On page load, I see a custom link call followed by a page call. Only the page call includes eVar5 (v5=General). Because of this eVar5 is undefined/unspecified for at least one call during the visit (the very first call), resulting in the "Unspecified" line item in your reports.

bindukumari1990
Level 4
Level 4

@evolytics_brian So, basically all my custom calls i.e. s.tl() link call should set evar5 in the respective rules. Right?

amgup
Level 7
Level 7

@bindukumari1990 Yes, evar5 should be set in s.linkTrackVars when the respective s.tl() call will be sent so that the evar5 is visible in the custom link call.

evolytics_brian
Community Advisor
Community Advisor

@bindukumari1990 - You are seeing "Unspecified" in the eVar5 report because the variable is not being set until (at least) the second analytics call of the visit. To address this, you need to make sure eVar5 is populated on the first call of each visit. In your case, that is the s.tl() call. 

 

So, to answer your question: Yes. Make sure the s.tl() calls include the appropriate eVar5 value.