Problems with Reporting API header.

Avatar

Avatar
Level 1
benr51112496
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile

Avatar
Level 1
benr51112496
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile
benr51112496
Level 1

01-06-2016

Hi there, 

A client of mine is reporting the following issue. It seems that reporting API requests have ceased working, and my resource believes it be related to the header, as it has been a problem previously. Has there been a change to the way request headers should be configured? Client Care is moving very slowly, so I wanted to post this and see if anyone here had helpful insight for us. 

 

"We are calling omniture api to pull the top bios & shows. Its was working fine with “<wsse:Security xmlns:wsse="http://www.omniture.com" wsse:mustUnderstand="1”>” header until march 8th but now it stopped working, Last november same issue happened and you asked us to change the request header and then it started working. We don’t know what has to be in header now so we tried with old header “<wsse:Security SOAP-ENV:mustUnderstand="1”>” but both are not working. When we use new header then it returns invalid user in response and old header returns empty array. Please find the response screenshots below."

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1000
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

339 likes

Total Posts

2,340 posts

Correct reply

819 solutions
Top badges earned
Validate 1000
Springboard
Validate 500
Validate 250
Validate 100
View profile

Avatar
Validate 1000
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

339 likes

Total Posts

2,340 posts

Correct reply

819 solutions
Top badges earned
Validate 1000
Springboard
Validate 500
Validate 250
Validate 100
View profile
jantzen_belliston-Adobe
Community Manager

24-02-2021

Since this is an older post, I'm assuming you've solved this issue. Incase others find this post, I'll post the link to the documentation below:

https://experienceleague.adobe.com/docs/analytics/analyze/analytics-reporting-api/c-reporting-api.ht...

Answers (0)