Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Analytics Champion Program are open!
SOLVED

How to filter the AEM health checker (user agent Envoy/HC) from our stats?

Avatar

Level 2

Anyone experience the AEM health checker artificially inflating their stats?

 

Out website traffic has significantly increase and upon further investigate, we're seeing the traffic is coming from the AEM Health Checker, using the user agent Envoy/HC. 

We've tried filtering the traffic with the bot rules, however the Health Checker isn't using a static IP address. 

Thanks in advance for any advice here.  

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Wow... so it's not just "contains".. that's literally the entire string!

 

Have you tried contains "Envoy", that doesn't seem like it would show up in a lot of other user agents.... (this at least can check if the / is confusing things)

 

And you are sure that this data is coming into your tracking suite? Do you have an eVar set up to track the user agent that you can use to confirm..

 

The only other place you can get User Agent from your Adobe Data, that I am aware of, is your Raw Data feeds... but this you have to be careful of, since there is a special exclude data column and other processing that you need to take into consideration... and if you don't already have a process in place may not be a good option.

 

Or maybe you are confirming this simply by running in an isolated Dev environment and correlating the traffic in a Dev suite... I can see that what you sent is a server log, not from Adobe Analytics itself... so it's always a good idea to check everything

View solution in original post

5 Replies

Avatar

Community Advisor

Rather than using IP for your bot rule, could you not set up a rule based on User Agent contains?

 

Jennifer_Dungan_0-1674760165454.png

 

Avatar

Level 2

We set-up that exact bot rule, but it is not filtering the traffic. This is why we're so perplexed. 

sbridgeman_0-1674761181216.png

 

Avatar

Community Advisor

Hmm interesting... maybe case sensitivity? Maybe the / is causing issues?

 

I don't really use the Health Check, can you post the full user agent string that you have collected? 

Avatar

Correct answer by
Community Advisor

Wow... so it's not just "contains".. that's literally the entire string!

 

Have you tried contains "Envoy", that doesn't seem like it would show up in a lot of other user agents.... (this at least can check if the / is confusing things)

 

And you are sure that this data is coming into your tracking suite? Do you have an eVar set up to track the user agent that you can use to confirm..

 

The only other place you can get User Agent from your Adobe Data, that I am aware of, is your Raw Data feeds... but this you have to be careful of, since there is a special exclude data column and other processing that you need to take into consideration... and if you don't already have a process in place may not be a good option.

 

Or maybe you are confirming this simply by running in an isolated Dev environment and correlating the traffic in a Dev suite... I can see that what you sent is a server log, not from Adobe Analytics itself... so it's always a good idea to check everything