Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Analytics Implementation 101 and Adobe Cookies

Avatar

Level 3

I´m doing my first analytics implementation on a new website for the company. All the previous ones were done by a consulting company and each website differently. 

I´ve done all the launch setup (extensions, rules, data elements) with the extensions and the script was inserted into the website. 
However, by comparing it with some of our other websites, I realized that some of them have the AppMeasurement and activitymap js scripts. Reading the documentation it says if you do the setup by launch you don't need the appmeasurement scripts. so I got super confused about why the js are in the sites.

So here comes another question, in case I have to add the JS to the new site, where do I can the correct code? I realized that each code has an ID on it.. I believe this new site will need one also: 
src="https://assets.adobedtm.com/extensions/xxxxxxxxxxxxxxxxxxx/AppMeasurement.min.js", 
src="https://assets.adobedtm.com/extensions/EPxxxxxxxxxxxxxxxxx/AppMeasurement_Module_ActivityMap.min.js"

And this leaves me with my last question. when testing in development, all the cookies were fired without an issue and we were already getting data. we are using OneTrust for consent and block them.
However, in production, even if the consent is yes the Adobe cookies are not being fired. the Onetrust code is exactly the same (so is the website code), just the URL and server are not. We were wondering if the cause is because the URL is a subdomain from our main site, but this error never happened with our other sites which are also subdomains. That's when I started looking for the code differences and found the situation first described in this post. I don't know if there is a relationship with them.

I also already tried to go to adobe analytics extensions, and cookies and change the Domain Periods to 3 (another post from the community suggested that) but also didn't work.

Any idea of what can be causing the cookies not to fire? and should I have done something different in the implementation? 
thanks in advance

1 Accepted Solution

Avatar

Correct answer by
Level 2

Hi fern1, 

 

There are multiple questions you have asked. I can probably answer the first one:

 

The method of adding AppMeas and the activity map that you have mentioned in the query above is the legacy method. But as you yourself mentioned, if you are using Launch you don't need to worry about adding the AppMeas and Activity Map modules separately. Launch will automatically take care of the two once you enable. You just need to ensure the Launch script is at the bottom of the </head> tag.

 

With regards to the Cookie query, do you have any test URL wherein one can check the behavior. Also, how are you listening for the OneTrust consent? Do you use the Extension?

View solution in original post

4 Replies

Avatar

Correct answer by
Level 2

Hi fern1, 

 

There are multiple questions you have asked. I can probably answer the first one:

 

The method of adding AppMeas and the activity map that you have mentioned in the query above is the legacy method. But as you yourself mentioned, if you are using Launch you don't need to worry about adding the AppMeas and Activity Map modules separately. Launch will automatically take care of the two once you enable. You just need to ensure the Launch script is at the bottom of the </head> tag.

 

With regards to the Cookie query, do you have any test URL wherein one can check the behavior. Also, how are you listening for the OneTrust consent? Do you use the Extension?

Avatar

Level 3

about the onetrust, I don't know much has it has been done since the onetrust team is dealing directly with the devs, but I do know the block is done through the script.. they run a scan and give you the scripts to be inserted in the website.

The test link unfortunately doesn't work outside our company Ip. 

Avatar

Level 3

Thank you for your help!


I told the dev that I believed the adobe script should come after the onetrust one since we have like that in our other sites but he insisted it wasn´t the case since they had the property async on to load them simultaneously.

After your comment, I asked him to test it just in case, and it worked! We just had to switch the order of the scripts.
Thanks for your help.