Highlighted

DTM, click event throws "SATELLITE: Error - Failed to load script".

gustav_spross

15-10-2015

Edit:

The issue with right button mouse click starting the link navigation event (when "delay link activation" is checked) is only occuring in Firefox. Chrome works fine and does not fire off the click rule when using right mouse button...

 

///

Hi,

I'm new to DTM and trying to get tags to fire on link clicks. I have set up a click event with a css-selector and I can see that the rule fires in the debugger when I click my link. How ever, just after this line in the console:

SATELLITE: Rule "Search Result General Click (Text)" fired.

I get this error:

SATELLITE: Error - Failed to load script http://assets.adobedtm.com/xxx/scripts/satellite-xxx.js

 

I thought that the issue might be due to the code in my event not having enought time to execute before the link is activated, so I checked the "delay link activation"-box, but this did not solve the issue and also triggered my links to navigate when I right click...

 

Questions:

  1. Why do I get the failed to load script error and how can it be solved?
  2. Why does my click events trigger on right mouse button click? Is it possible to only trigger rules and navigation when the left mouse button is used?

Replies

Highlighted

Rudi_Shumpert

Employee

15-10-2015

Gustav,

Is there a url where we can see this happening?

You can email directly with account name and info if you prefer not to post the details here.

-Rudi

Highlighted

ParitMittal

03-10-2016

Hi Laura , 

Can you please share your DTM account details in a private message as well as URL of the website so that we can debug the issue at our end.

Thanks & Regards

Parit Mittal

Highlighted

JillsMatthew

08-05-2018

Did anyone find any solution for this problem?

I am having the same issue. The code to include my sequential javascript throws error on IE & Firefox, but the same code works without any issues on Chrome.

Highlighted

jantzen_belliston-Adobe

Community Manager

08-05-2018

This thread is pretty old, I'd encourage you to create a new question on the Dynamic Tag Management​ community with all the details you can provide. This will allow all of our users to see your question and provide possible solutions.