Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Using Adobe Launch Target V2 it is required to use getOffers and applyOffers?

LucasSAndrade
Level 2
Level 2

In my SPA I impleted Target only with triggerView (in the Target V2 extension of Launch).

In the VEC I can see all viewnames and navigate through. But when I make some changes and go check it out in QA link I cannot see my changes on the page, it only works if it's a page with page load.

Soo my acitivitys need adobe.target.getOffers and adobe.target.applyOffers to work? I'm missing something?

1 Accepted Solution
LucasSAndrade
Correct answer by
Level 2
Level 2

I figured out the error. It was a simple mistake.

My pages lost parameters because my website try to process it. Soo I ask my dev team to whitelist Adobe Target QA and debugger parameters.

And it has a redirect to an index page at first load. Soo my activitys on this page should contain an additional rule. In my case I use the "domain starts with" rule.

View solution in original post

6 Replies
pradeepr6574026
Level 2
Level 2

Hi LucasSandrade,

                            As you said, using Target V2 extension - Can you please provide the steps , how you got the all viewName inside  VEC.

Inside the Launch apart from extension installation, did u created any rule to get the viewName

What action did you set?

Did you added any code to the code editor.

LucasSAndrade
Correct answer by
Level 2
Level 2

I figured out the error. It was a simple mistake.

My pages lost parameters because my website try to process it. Soo I ask my dev team to whitelist Adobe Target QA and debugger parameters.

And it has a redirect to an index page at first load. Soo my activitys on this page should contain an additional rule. In my case I use the "domain starts with" rule.

View solution in original post

pradeepr6574026
Level 2
Level 2

Hi Lucas,

               I need some help on this.

To get the all the viewName in the Vec, Can you please provide the steps?

My  Spa Built with Angular

When i see the Target request in the network with delivery filter i saw 204 status code, i dont see any response.

Could you please provide the steps to get all View in the VEC

LucasSAndrade
Level 2
Level 2

I use Launch to implement Target on this SPA.

1- First of all in Launch we need to instal the Target extension. In SPA it's recomended to go with Target V2;

2- Then I create a rule to Load Target in page. I use Library Load (page top) event. In actions you only need a Load Target and Fire Page Load Request actions, in my case I use Add Params to All Requests to use in my scenario too but its not mandatory.

3- In the second rule I set a Custom Event. Basicaly we need to send a event in every page view, something like this to trigger this event:

        var evt = new CustomEvent('Your-Event-Trigger');

        document.body.dispatchEvent(evt);

And then use your event trigger on the rule custom event.

In actions I use "Add Params to Page Load Request" and "Trigger View". In Trigger View I use a data element with my page names. But you can use something like document.location.pathname if you dont have a data layer. I check Page option because I want to count every triggerView as page view.

And that's it. You are ready to see Views names in VEC.

pradeepr6574026
Level 2
Level 2

Hi Lucas,

           Thanks for the Steps.

As you said , I configured everything with in the launch.

I see the view name in the

delivery request with status code : 204

Response header : Connection : Close

Instead of xhr , I see

Content-Type:  text/plain;charset=UTF-8

Then under response tab, This request has no data available.

In the VEC - Under Modification, I see only Page load event.

I dont see the current viewName

One query - I installed Target v2 extension, if this is the case do we need to add at.js to be added to the website.

Thanks for the steps provided

Regards,

Pradeep

pradeepr6574026
Level 2
Level 2

Hi Lucas ,

Our site built with Angular (SPA)       

As you said, I have created two rules and added respective action inside the launch.

for the Trigger View I use a data element with my page names

One clarification - where should i need to add the custom evt in the Application or site.

I’m seeing the different views  Plus on page load it is injecting the offer.

It’s not injecting the offer on the page for Views (and doesn’t show the changes within the VEC). I’m noticing that the delivery call only fires on page load – it should load with each view change .

Any inputs?

Thanks in Advance.