Web servers are stripping parameters from my URLs after redirect.

Avatar

Avatar
Boost 3
Level 2
koolswap
Level 2

Likes

3 likes

Total Posts

6 posts

Correct reply

0 solutions
Top badges earned
Boost 3
Boost 1
View profile

Avatar
Boost 3
Level 2
koolswap
Level 2

Likes

3 likes

Total Posts

6 posts

Correct reply

0 solutions
Top badges earned
Boost 3
Boost 1
View profile
koolswap
Level 2

13-02-2019

I have a issue where Web servers are stripping  adobe_mc_sdid and adobe_mc_ref parameters from my URLs after redirect. I have:

1. The system minimum requirement looks good.

2. Parameters are white listed.

3. I am using Adobe launch where we have all setup.

Replies

Avatar

Avatar
Coach
Employee
mikewebguy
Employee

Likes

635 likes

Total Posts

402 posts

Correct reply

85 solutions
Top badges earned
Coach
Contributor
Shape 25
Shape 1
Shape 10
View profile

Avatar
Coach
Employee
mikewebguy
Employee

Likes

635 likes

Total Posts

402 posts

Correct reply

85 solutions
Top badges earned
Coach
Contributor
Shape 25
Shape 1
Shape 10
View profile
mikewebguy
Employee

13-02-2019

koolswap​,

1. Have you tried asking the web-server admin if they can adjust the configuration to make it so redirect to xyz won't strip the URL parameters?

2. There is an option in the UI when you set up a redirect to preserve parameters also make sure this is checked.
Hope this helps!

Mihnea Docea | Technical Support Consultant | Customer Experience | Adobe | (:: 1 (800) 497-0335

Avatar

Avatar
Boost 3
Level 2
koolswap
Level 2

Likes

3 likes

Total Posts

6 posts

Correct reply

0 solutions
Top badges earned
Boost 3
Boost 1
View profile

Avatar
Boost 3
Level 2
koolswap
Level 2

Likes

3 likes

Total Posts

6 posts

Correct reply

0 solutions
Top badges earned
Boost 3
Boost 1
View profile
koolswap
Level 2

17-02-2019

Thanks for the reply,

For #1:

Redirects are still working on our non-launch version. The issue is only with Launch version.

For #2.

We always select the "Include Current Query parameters", so this looks fine.

Is there any configuration that needs to be done in Adobe Launch?

Kindly suggest.

Avatar

Avatar
Boost 3
Level 2
koolswap
Level 2

Likes

3 likes

Total Posts

6 posts

Correct reply

0 solutions
Top badges earned
Boost 3
Boost 1
View profile

Avatar
Boost 3
Level 2
koolswap
Level 2

Likes

3 likes

Total Posts

6 posts

Correct reply

0 solutions
Top badges earned
Boost 3
Boost 1
View profile
koolswap
Level 2

20-02-2019

Any suggestion yet...