Cannot edit custom code, getting various errors

Avatar

Avatar
Validate 1
Level 1
nick_so
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
nick_so
Level 1

Likes

0 likes

Total Posts

4 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
nick_so
Level 1

17-02-2017

My developers are having troubles trying to edit code on Target experiences. We have editor permissions on the account and have been able to do so in the past, but now we are running into a few issues.

First, in the visual editor we notice we are getting the following error:

Sorry, we are experiencing an internal server error.
Try reviewing VEC best practices

We don't make changes through the visual editor, so that's fine but not sure if it's related to the issue.

Secondly, if we press next, we get the following error:

ERROR   These changes cannot be saved. The selected website does not contain Target libraries.

I can verify there is a Target mbox on the URL being targeted and that there are no other tests running on this particular page (however there are tests running on other pages of this site using the same mbox; we have not had issues with this in the past).

Please advise.

Replies

Avatar

Avatar
Validate 10
Level 10
ParitMittal
Level 10

Likes

93 likes

Total Posts

817 posts

Correct reply

349 solutions
Top badges earned
Validate 10
Validate 1
Boost 50
Boost 5
Boost 3
View profile

Avatar
Validate 10
Level 10
ParitMittal
Level 10

Likes

93 likes

Total Posts

817 posts

Correct reply

349 solutions
Top badges earned
Validate 10
Validate 1
Boost 50
Boost 5
Boost 3
View profile
ParitMittal
Level 10

20-02-2017

Hi Nick,

Can you please share your Target Account credentials in a private message so that we can debug the issue at our end ?

Thanks & Regards

Parit Mittal

Avatar

Avatar
Boost 1
Level 1
Harry_S
Level 1

Like

1 like

Total Posts

2 posts

Correct reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
Harry_S
Level 1

Like

1 like

Total Posts

2 posts

Correct reply

0 solutions
Top badges earned
Boost 1
View profile
Harry_S
Level 1

21-02-2017

@Nick Looks like the problem is not related to custom code but about loading page inside VEC

1. Have you toggle Enhanced Experinece Composer flag for your account?

2. Also can you share the url of the activity you are trying to edit?