Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

User completed task but next step is not created

Avatar

Level 4

Hi all,

My workflow is like that:

1)User A submit

2)Update database

3)Form is routed to user B

4)User B make some comment submit

5)Update dabase

6)Form is routed back to user A.

However after user B submit the task (step 4), the step 5 is not generated.

From adminui > Process Management, I see step 4 (User Task) is still running, but when I view the details of the step, the status of the task is "COMPLETE"

I wait for quite long time but next step is never created.

During that time we did not change anything in the workflow.

Is there any idea why this problem happens?

Thank you and regards,

Anh

5 Replies

Avatar

Level 10

If you use Record and Playback, doesn't stop on User B step?

Jasmin

Avatar

Level 4

Hi Jasmin,

Thank you for your reply. This situation happens very rarely. I never encounter this problem before. And today when user tested, it happened for 1 case.

Tomorrow I will try again. But users are asking me why it happen in this particular case...

Regards,

Anh

Avatar

Level 10

Do you have any conditional route after step4?

If so, make sure that there are no Stalled Branch errors.

ps: Check the Stalled Branch errors section from adminui (not Stalled actions).

Nith

Avatar

Level 8

Did you check the database log? It might provide some clues.

Avatar

Level 4

Hi Scott and Nith,

Thank you for your reply.

I have check server log file and see StackOverFlowError in these cases.

It happens only in peak hour, when server runs other applications. In most of the cases, after 20 minutes, the workflow is auto-recovered and run normally.

I suspect this is because of StackOverFlowError which i have created another thread.

I have contacted Adobe to get the quick fix for StackOverFlow.

Now i am observing the behaviour of the server after installation. 

Regards,

Anh