Expand my Community achievements bar.

Learn about Edge Delivery Services in upcoming GEM session

Unable to Validate Database Resource with ES4, WebSphere 8.5, and SQL Server 2008R2

Avatar

Level 1

I've been attempting to deploy ES4 on Windows 2008R2, SQL Server 2008R2 (which is on a separate server), ontop of IBM WebSphere 8.5.  I've followed the current Adobe ES4 instructions but I cannot get past the "Datasource Validation" step, receiving the following error:

IDP_DS Fail

Name:IDP_DS

  JNDI:

  http://TDAEM01.fsis.dev:9080/adobe-lcm-lcvalidator/validate?validation_type=DS_validation&DS_jndi_na...

  ALC-LCM-120-300: Data source settings failed validation.

RM_DS Fail

  Name:EDC_DS

  JNDI:

  http://TDAEM01.fsis.dev:9080/adobe-lcm-lcvalidator/validate?validation_type=DS_validation&DS_jndi_na...

  ALC-LCM-120-300: Data source settings failed validation.

I've searched all over the message boards but I cannot find a clear, concise answer for this problem.  Please help.  This is the output of my System.out log:

6 Replies

Avatar

Employee Advisor

Firstly, make sure you are on a supported platform specially Websphere : LiveCycle Help | Adobe LiveCycle ES4 Supported Platforms (check out ES4/ES4SP1 differences).

Thanks

Wasil

P.S. : 8.5.5 is not supported yet. But 8.5.0 should work.

Avatar

Level 1

I have 8.5 not 8.5.5, so that isn’t a problem. I’m going to try installing ES4 SP1 and see what happens.

Avatar

Employee Advisor

In case you see the datsources in Websphere Console and you are able to test them successfully, but LCM fails the validation, you can ignore that and proceed to the next step. Here is one related thread : failing the datasource validation

-Wasil

Avatar

Level 1

I uninstalled and re-installed Java and was able to validate the data sources. However, I’m currently on the “Component Deployment” phase. All the jar files seemed to deploy successfully except for the lca files. I’m receiving the following:

Failed to deploy LCA C:\Adobe\Adobe LiveCycle ES4\deploy\adobe-livecycle-launchpad.lca

Failed to deploy LCA C:\Adobe\Adobe LiveCycle ES4\deploy\adobe-livecycle-launchpad-assets.lca

Failed to deploy LCA C:\Adobe\Adobe LiveCycle ES4\deploy\adobe-livecycle-launchpad-navigators.lca

Avatar

Employee Advisor

You should have configured the time out values in Websphere : http://help.adobe.com/en_US/livecycle/11.0/InstallWebSphere/WS1a95df6a070ac5e3cb56e2412fc39ceeda-7ff...

Also, make sure to set the correct Transaction Isolation Level in SQl Server as READ_COMMITTED_SNAPSHOT set to ON : Adobe LiveCycle ES4 * 5.4 Creating a SQL Server database

The failed LCAs are related to Launchpad which is a desktop application to access LiveCycle services, so could be skipped for now. You can remove those LCAs from adminui and re deploy them again from C:\Adobe\Adobe LiveCycle ES4\deploy.

If that doesn't work, drop the database and bootstrap the database using LCM again(If you are going to use Launchpad).

Thanks

Wasil

Avatar

Level 1

Looks like the time out values were configured properly through LCM and I am running the query per your instructions. This thread is resolved. Thank you very much for your help.