Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

The Long Lived Service cannot be invoked synchronously.

Victoria_Agafon
Level 3
Level 3

Hello every one!

I'm new to the LC, and i'm trying to create process in workbench, which consists of 2 start points (the default and The Workspace start point) and one Assign Task.

So, after deploying my process to the server, i'm trying to start it from workspace. And i'm getting an error. JBoss logs has some info about it:

A problem occurred in the Render Service for Task "102".  Please review the render orchestration for this process.

...

Caused by: com.adobe.idp.taskmanager.dsc.client.task.TaskManagerException: Error Invoking render Operation For (taskId, formId):(102 ,0).  Error Message is:

The Long Lived Service Test123/Processes/NewProcess1 cannot be invoked synchronously.

So, where can i get render orchestration for this process to fix it, or, what  else can i configure/fix to solve this problem?

6 Replies
ckkovac
Level 1
Level 1

I suspect the process type is set to "short-lived", instead of "long-lived".  In Workbench, right-click on the process and select "Configure...".  Navigate to the Advanced tab.  Under Run Time Settings, ensure the Type is set to "long-lived".  Save and re-deploy the process.  

Victoria_Agafon
Level 3
Level 3

Ckkovac, thank you for your reply!

Unfortunatly, it's not so, cause my process is long-lived. And even if i try to make it short-lived, the workbench does not let me do so with such warning:

"The service or gateway 'Step' referenced by this Process requires a process type 'long-lived'. You must remove this node prior to setting the process type to 'short-lived'. "

So, the process it-self is long-lived.

Also, i've tried to put .swf form from sample process to my process. And it works good with it.

But when i try to create form (not swf) and configure process to use it, i recieve this one error. So, it's looks like that the form "thinks" that my process is short-lived. (Well, i can be wrong here, cause i still don't know much about LC architecture)...

ckkovac
Level 1
Level 1

Is your form an XDP or PDF?  If so, did you create it in Designer from within Workbench (i.e. is the Form Bridge or the Process Fields on the form)?

laurent_trapp
Level 1
Level 1

HALLO

SORRY BIN AUF DEM TASTE VOM LEPTOP GEKOMMEN WAR MEIN FEHLER;

WAS KANN ICH TUN ER FÄHRT NICHT MEHR HOCH`? BIETE UM ANTWORT: WAS sOLL  ICH JETZT TUN ?

ssei so lieb  bitte um hilfe !!! im voraus DANKE

Victoria_Agafon
Level 3
Level 3

I've tried both, and the result is the same...

I've tried to create it both from the very begining in Workbench 10.0 and by fetching sample process from the server.

Victoria_Agafon
Level 3
Level 3

I've noticed this one error: right after i create a new application with new process in Workbench, i recieve this one error:

So, in Manage Action Profiles i've tried to create new Render and Submit Processes.
But then i recieve new errors:
                                             
So, when i open this process, there are 2 steps: "Default startpoint" and "Render PDF Form". And when i click on the Render PDF Form, in the Process Properties tab i can find an error message: failed to load service operation for process. And on the Services tab, in the tree, i can not find such service either...