Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

renderHTMLForm fails - path not found.

YorickErnst
Level 1
Level 1

I'm trying to get a simple proces working with workbench.

A template and data are loaded into variables and then the function renderHTMLForm is called with these variables as input.

All this is triggered by a REST call. http://192.168.4.163:8080/rest/services/uploadForm/renderHTML:1.0

And each time the following error is given:

HTTP Status 500 - DSCError: ComponentID= DSC ErrorCode= 3 MinorCode= 0 Message= Invocation error. ErrorMessage: Invocation error. caused by: C:\Windows\Temp\AdobeForms_adobejb_server1\Cache\1376488075893\Disk_Cache\rO0ABXNyABZjb20uYWRvYmUuaWRwLkRvY3VtZW50yAEFUxsO%2BCEDACNJAAtfY2FsbGJhY2tJZFoADV9kZXNlcmlhbGl6ZWRJABBfZGlzcG9zYWxUaW1lb3V0WgAJX2Rpc

3Bvc2VkWgAZX2lzRGlzcG9zYWxUaW1lb3V0RGVmYXVsdFoAE19pc1RyYW5zYWN0aW9uQm91bmRKAAdfbGVuZ3RoSQAOX21heElubGluZVNpemVaAAhfb3duRmlsZVoAC19wYXNzaXZhdGVkWgALX3BlcnNpc3RlbnRJABFfc2VuZGVyQ2FsbGJhY2tJZFoAEV9z

ZW5kZXJQYXNzaXZhdGVkWgARX3NlbmRlclBlcnNpc3RlbnRJAA5fc2VuZGVyVmVyc2lvbkkABl9zdGF0ZUwAC19hdHRyaWJ1dGVzdAATTGphdmEvdXRpbC9IYXNoTWFwO0wACF9jYWNoZUlkdAAfTGNvbS9hZG9iZS9pZHAvRG9jdW1lbnRDYWNoZUlEO0wADF9jYW

xsYmFja1JlZnQAIUxjb20vYWRvYmUvaWRwL0lEb2N1bWVudENhbGxiYWNrO0wADF9jb250ZW50VHlwZXQAEkxqYXZhL2xhbmcvU3RyaW5nO0wAC19kYXRhQnVmZmVydAAeTGNvbS9hZG9iZS9zZXJ2aWNlL0RhdGFCdWZmZXI7TAAPX2V4cGlyYXRpb25UaW1ldA

AQTGphdmEvbGFuZy9Mb25nO0wABV9maWxldAAOTGphdmEvaW8vRmlsZTtMABBfZ2xvYmFsQmFja2VuZElkdAAhTGNvbS9hZG9iZS9pZHAvRG9jdW1lbnRCYWNrZW5kSUQ7WwAHX2lubGluZXQAAltCTAAMX2lucHV0U3RyZWFtdAAVTGphdmEvaW8vSW5wdXRT

dHJlYW07TAAPX2xvY2FsQmFja2VuZElkcQB%2BAAhMAAxfcHVsbFNlcnZhbnR0ACRMY29tL2Fkb2JlL2lkcC9JRG9jdW1lbnRQdWxsU2VydmFudDtMABFfcmFuZG9tQWNjZXNzRmlsZXQAGkxqYXZhL2lvL1JhbmRvbUFjY2Vzc0ZpbGU7TAAVX3NlbmRlckNhbGxiYW

NrUmVmSU9ScQB%2BAARMABZfc2VuZGVyR2xvYmFsQmFja2VuZElkcQB%2BAAhMAA1fc2VuZGVySG9zdElkcQB%2BAARMABVfc2VuZGVyTG9jYWxCYWNrZW5kSWRxAH4ACEwAGl9zZW5kZXJQdWxsU2VydmFudEpuZGlOYW1lcQB%2BAARMAARfdXJs

dAAOTGphdmEvbmV0L1VSTDt4cHcGAAAAAwAAcHcpACcxMjcuMC4wLjEvLy8vLy8vLy8vMTkyLjE2OC40LjE2My8vLy8vLy9wcHB6AAAC0gLMSU9SOjAwMDAwMDAwMDAwMDAwMjg0OTQ0NEMzQTYzNkY2RDJGNjE2NDZGNjI2NTJGNjk2NDcwMkY0OTQ0NkY2

Mzc1NkQ2NTZFNzQ0MzYxNkM2QzYyNjE2MzZCM0EzMTJFMzAwMDAwMDAwMDAyMDAwMDAwMDAwMDAwMDEwMDAwMDEwMjAwMDAwMDAwMEUzMTM5MzIyRTMxMzYzODJFMzQyRTMxMzYzMzAwMERDODAwMDAwMDE1MzgzODMxMzkzMDMxM

zYzNTMzMzEyRjAwMTgwMTRBNDIwQjQ4Mjg0QzE1MDAwMDAwMDAwMDAwMDUwMDAwMDAwMDAwMDAwMDA4MDAwMDAwMDA0QTQxNDMwMDAwMDAwMDAxMDAwMDAwMjAwMDAwMDAwMDA1MDEwMDAxMDAwMDAwMDEwMDAxMDAwMTAwM

DEwMTA5MDAwMDAwMDIwNTAxMDAwMTAwMDEwMTAwMDAwMDAwMjEwMDAwMDA3MDAwMDAwMDAwMDAwMDAwMDEwMDAwMDAwMDAwMDAwMDI0MDAwMDAwMjAwMDAwMDA3RTAwMDAwMDAwMDAwMDAwMDEwMDAwMDAwRTMxMzkzMjJF

MzEzNjM4MkUzNDJFMzEzNjMzMDAwREM5MDA0MDAwMDAwMDAwMDAwODA2MDY2NzgxMDIwMTAxMDEwMDAwMDAxNzA0MDEwMDA4MDYwNjY3ODEwMjAxMDEwMTAwMDAwMDA3NjQ2NTY2NjE3NTZDNzQwMDAwMDAwMDAwMDAwMDAwMDAwM

DAwMDAwMDAwMDAwMDAwMDAwMDAwMjAwMDAwMDAwNDAwMDAwMDAwMDAwMDAwMUYwMDAwMDAwNDAwMDAwMDAzMDAwMDAwMDEwMDAwMDAyMDAwMDAwMDAwMDAwMDAwMDIwMDAwMDAyMDAwMDAwMDA0MDAwMDAwMDAwMDA

wMDAxRjAwMDAwMDA0MDAwMDAwMDMAAAAocHBzcgARamF2YS51dGlsLkhhc2hNYXAFB9rBwxZg0QMAAkYACmxvYWRGYWN0b3JJAAl0aHJlc2hvbGR4cD9AAAAAAAAMdwgAAAAQAAAABXQACGJhc2VuYW1ldAAMdGVtcGxhdGUueGRwdAARQURPQk

VfSU5JVElBTF9VUkl0ADZyZXBvc2l0b3J5Oi8vL0FwcGxpY2F0aW9ucy91cGxvYWRGb3JtLzEuMC90ZW1wbGF0ZS54ZHB0AApBRE9CRV9VVUlEdAAZanB2OG04Ym5xMGw5aGdzN2pvNjR5Znc5eXQAA3VyaXEAfgAUdAADdXJscQB%2BABR4dzcALWFkb2JlL2lk

cC9Eb2N1bWVudFB1bGxTZXJ2YW50L2Fkb2JlamJfc2VydmVyMf%2F%2F%2F%2F%2F%2F%2F%2F%2F%2FeA%3D%3D\.lock (The system cannot find the path specified)

Under Services - Lifecycle Forms ES3 - Locations, I ticked "LC Temp Directory" for the Cache location. (Which is C:\Windows\Temp)

Why is it failing? Is it because the path is so long? If so why is it so long?

Any help is greatly appreciated

4 Replies
Varun_Nohria
Level 3
Level 3

Please attach the LCA file (which has this process) which you have used.

I will deploy it at my end and check its sanity.

Regards,

Varun Nohria

Varun_Nohria
Level 3
Level 3

I just changed the 'renderHTMLForm' activity to 'renderPDFForm' and I was able to render the form successfully.

Now I am thinking whether the XDP you created has considerations for HTML forms or not. Please check the below link which gives information about creating HTML forms:

http://help.adobe.com/en_US/livecycle/10.0/DesignerHelp/WS92d06802c76abadb-391c25bf129b8b01861-7fd3....

Regards,

Varun Nohria

YorickErnst
Level 1
Level 1

We just tried the renderPDFForm and it works as well so we can rule out LC environment issues.

So on further inspection of the process we found that if we output the result of the renderHTMLForm function into a variable and use that as the end result it works fine.

So the problem was just that LC didn't know what to do with the output.

Thanks again for your help on this.