Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Problems authenticating

Avatar

Level 3
Today I am having issues authenticating as an owner for my
room. I am confident that the username and password is correct and
was previously working. It also seems to work fine with the
AFCSDevConsole.



Here's the message I get:



[SWF]
Users:stefan:Desktop:CocomoSDK_0.91:examples:SharedCollection:bin-debug:SharedCollectionExample.swf
- 1,164,600 bytes after decompression

AFCS Beta Build # : 0.91

requestInfo
http://connectnow.acrobat.com/flashcomguru/demoroom?mode=xml&x=0.4336960185319185

getMeetingInfo: status=0

Getting FMS at
https://na2.connectnow.acrobat.com/fms?ticket=153pgl0yo7l10,
attempt #1/3

result: <fms>

<origin>fms5.acrobat.com</origin>

<proto_ports>rtmps:443</proto_ports>

<retry_attempts>2</retry_attempts>

</fms>

#FMSConnector# Sat Feb 28 21:24:11 GMT+0000 2009 protocols:
[object ProtocolPortPair]

#FMSConnector# Sat Feb 28 21:24:11 GMT+0000 2009 [attempt 1
of 2] Connecting to 0/0:
rtmps://fms5.acrobat.com/cocomo/na2-sdk-bc8c04f1-df86-4669-a205-550fc23851af/demoroom
#startProtosConnect#

#FMSConnector# Sat Feb 28 21:24:12 GMT+0000 2009
tempNetStatusHandler 0/1,NetConnection.Connect.Success

#FMSConnector# Sat Feb 28 21:24:12 GMT+0000 2009 isTunneling?
false

#FMSConnector# Sat Feb 28 21:24:12 GMT+0000 2009 is using
RTMPS? true

RECEIVED LOGIN AT SESSION

.user descriptor from server [object]

\\

.affiliation [number]= 5

.role [number]= 10

.displayName [string]= stoem

.userID [string]= GUEST-E1B8C4D6-8E4F-4532-B219-D49A13DB3140

RECEIVENODES UserManager

receiveAllSynchData UserManager

RECEIVENODES FileManager

receiveAllSynchData FileManager

checkManagerSync:[object FileManager]

RECEIVENODES AVManager

receiveAllSynchData AVManager

checkManagerSync:[object StreamManager]

RECEIVENODES RoomManager

receiveAllSynchData RoomManager

checkManagerSync:[object RoomManager]

checkManagerSync:[object UserManager]

RECEIVENODES _dataSharedModel

receiveAllSynchData _dataSharedModel



I think there are two problems here. Firstly I think I should
authenticate as an owner with the credentials I pass. However maybe
this is a temporary glitch with the service.

The second issue (regardless of whether or not there is an
issue with the service atm) is that I think the service should
alert me of the fact that authentication failed. Simply logging me
on to the room as Guest seems wrong as I am assuming that
authentication succeeded using the credentials I passed, yet they
did not and my role was downgraded which is not obvious to spot.
Hope this makes sense.



Regards,



Stefan

1 Accepted Solution

Avatar

Correct answer by
Level 3
great, thank you. I never thought that the service was tight
to my session, now it makes sense. I'm able to log in as owner now.



thanks



Stefan

View solution in original post

3 Replies

Avatar

Level 10


Hi Stefan,



Likely the problem here is that you've gotten a session
established as a guest, and your browser is holding on to it, and
sending those session credentials no matter what. Try clearing
sessions or re-starting your browser. We're trying to figure out
how to avoid this for developers, but at least the good news is
that your users should pretty much never hit this issue.



thanks

nigrl

Avatar

Correct answer by
Level 3
great, thank you. I never thought that the service was tight
to my session, now it makes sense. I'm able to log in as owner now.



thanks



Stefan